概述

eNSP(Enterprise Network Simulation Platform)是一款由华为提供的免费的、可扩展的、图形化的网络设备仿真平台，主要对企业网路由器、交换机、WLAN等设备进行软件仿真，完美呈现真实设备部署实景，支持大型网络模拟，让你有机会在没有真实设备的情况下也能够开展实验测试，学习网络技术。

功能特色

  • 图形化操作

    eNSP提供便捷的图形化操作界面，让复杂的组网操作变得更简单，可以直观感受设备形态，并且支持一键获取帮助和在华为网站查询设备资料。

  • 高仿真度

    按照真实设备支持特性情况进行模拟，模拟的设备形态多，支持功能全面，模拟程度高。

  • 可与真实设备对接

    支持与真实网卡的绑定，实现模拟设备与真实设备的对接，组网更灵活。

  • 分布式部署

    eNSP不仅支持单机部署，同时还支持Server端分布式部署在多台服务器上。分布式部署环境下能够支持更多设备组成复杂的大型网络，内容详见灵活部署。

相关产品版本配套说明

产品名称 | 版本
AR | V200R003C00
S3700/S5700 | V200R001C00
CE6800 | VRP V800R011C00SPC607B607
CE12800 | VRP V800R011C00SPC607B607
WLAN | V200R007C10
USG5500 | VRP V500R003C07(产品侧为V1R2C02SPCa00)
USG6000V | V500R005C10SPC300
NE40E | VRP V800R011C00SPC607B607
NE5KE | VRP V800R011C00SPC607B607
NE9K | VRP V800R011C00SPC607B607
CX | VRP V800R011C00SPC607B607

免责声明

eNSP提供的模拟设备因为采用软件模拟，与真实设备间必然存在少量差异，若您遇到这些差异，请以真实设备实现为准。

重要声明

使用eNSP的CLOUD进行网卡绑定时，请务必不要绑定公共网络使用的网卡，否则可能会引起（如华为桌面云）动态地址池内网络故障，华为内部用户会涉及安全违规。

软件依赖

eNSP的正常使用依赖于WinPcap、Wireshark和VirtualBox三款软件，支持的版本如下：

软件类别 | 版本号
WinPcap | 4.1.3
Wireshark | 2.6.6
VirtualBox | 4.2.X-5.2.X

安装eNSP需要先安装好这三款软件，否则将会影响部分功能的使用。

问题反馈

您在使用中若有任何问题和建议，欢迎到华为企业业务技术支持论坛http://forum.huawei.com/enterprise/forum-753.html“eNSP”版块交流，感谢您的支持！

版权所有 © 华为技术有限公司


应用场景

eNSP帮助解决在网络教育领域的资源缺少问题，如学员和教师缺乏设备、网络。

eNSP构建了易用的、可扩展的图形化网络仿真工具平台，使学员和工程师能够很方便地学习网络知识、模拟组建网络、熟悉华为数通产品。

对于学生

eNSP是一款有趣的、灵活的软件。eNSP让您轻松地建立模型，进行网络实验。无论您将来是从事网络方面的工作，还是升学、认证、就业或个人实现，我们希望eNSP会对您有所帮助。您将获取到等同于操作实际网络设备的经验，这些有助于您成为网络专业人员。

对于讲师

eNSP是一款模拟的、可视化的、协作的网络教学工具。eNSP协助学生建构虚拟的网络，并在这些网络中执行数据包相关实验，直观感受到数据包的流动和网络协议的原理。

对于技术人员

eNSP是学习网络知识和模拟组网、熟悉华为数通产品的平台。eNSP让您方便地接触华为数通产品，学习网络特性与协议。通过eNSP平台，您可以方便地组建虚拟网络，模拟现网环境，比如维护时用于复现现网问题和组网交付前的预模拟等。通过加载最新的Demo版本产品仿真大包，您可以方便地体验产品的新特性。


设备特性列表

  • 园区交换机
  • AR路由器
  • WLAN设备
  • 防火墙
  • NE
  • CE交换机


园区交换机

阅读本章有助于您了解交换机支持的特性。

模拟交换机支持的特性如表1所示。

表1 交换机支持的特性

特性

子特性

描述

以太网特性

VLAN

支持全局VLAN特性、划分VLAN(基于MAC、端口、子网、协议)、MUX VLAN、VLAN 聚合

MAC
  • MAC地址自动学习和老化
  • 静态、动态、黑洞MAC表项
  • 接口/VLAN MAC地址学习限制
  • Sticky MAC、MAC防漂移、MAC端口安全

端口隔离

实现同一vlan内端口之间的隔

Ethernet
  • 以太三层接口
  • 链路聚合（包含Eth-Trunk创建、端口加入退出、Trunk Hash算法等，包含静态LACP以及对Eth-Trunk端口控制）

VLAN Mapping

支持单层Vlan Mapping、双层Vlan Mapping

QinQ

支持QinQ特性

GVRP

GARP的一种应用，用于注册和注销VLAN属性

以太环保护协议
  • STP、RSTP、MSTP
  • SEP

二层协议透明传输

支持基于接口、VLAN、QinQ的二层协议透明传输

Loopback Detection

支持Loopback Detection

IP业务

IP业务特性
  • VLANIF接口的IP地址
  • ARP
  • DHCP
  • DHCPv6
  • DHCP策略VLAN
  • UDP Helper
  • DNS
  • IPv6
  • IPv6 DNS

IPv4/IPv6协议栈

提供IPv4/IPv6地址管理、TCP/UDP Socket服务、ICMP协议、Ping/Tracert工具等功能服务

IP单播路由

单播路由特性
  • 静态路由
  • 路由策略、策略路由
  • RIP
  • RIPng
  • OSPF
  • OSPFv3
  • IS-IS
  • BGP
  • BGP+4
  • MBGP

IP组播

IGMP

支持IGMP特性

PIM（IPv4）
  • PIM-DM
  • PIM-SM

MSDP

支持MSDP特性

MLD Snooping

支持MLD Snooping特性

设备可靠性

BFD
  • BFD基本功能
  • BFD For OSPF
  • BFD For IS-IS
  • BFD For BGP
  • BFD For PIM

VRRP

支持VRRP特性

Smart Link

支持Smart Link特性

ERPS

支持ERPS（G.8032）特性

RRPP

支持RRPP特性

MPLS

静态LSP

支持静态LSP特性

MPLS LDP
  • LDP本地会话
  • 远端LDP会话
  • 使用LDP建立LSP
  • Transit LSP
  • LDP GTSM

VPN

MCE

MCE基本功能

VLL
  • CCC VLL
  • SVC VLL
  • Martini VLL

PWE3
  • 单跳动态PW
  • 纯静态PW多跳
  • 纯动态PW多跳
  • 静动混合多跳PW
  • 静态BFD检测PW
  • 动态BFD检测单跳PW
  • 动态BFD检测多跳PW

安全

AAA

提供认证、授权、计费三种安全功能

NAC

支持802.1x认证、MAC认证

ACL
  • 基本ACL
  • 高级ACL
  • 二层ACL
  • 自定义ACL

DHCP Snooping
  • DHCPv4 Snooping
  • DHCPv6 Snooping

QoS

MQC

支持基于流分类的优先级映射、优先级重标记、流量统计以及策略路由

网络管理

LLDP

支持链路层发现协议LLDP

NQA

支持DNS测试、ICMP测试

NTP
  • 单播客户端/服务器模式
  • 对等体模式
  • 广播模式
  • 组播模式
父主题： 设备特性列表


AR路由器

阅读本章有助于您了解AR路由器支持的特性。

模拟AR路由器支持的特性如表1所示。

说明：

通用路由器Router仿真设备只做保留，不再维护。

表1 AR路由器支持的特性
特性 | 子特性 | 描述
广域网互联 | WAN口 | 提供以太端口、同步串口。
 | 逻辑接口 | 支持Loopback、Tunnel、以太子接口。
 | PPP | 点到点链路层协议，主要用于在全双工的同异步链路上进行点到点的数据传输。
 | MP | 增加链路带宽和增强链路可靠性。
 | HDLC | 高级数据链路控制HDLC协议对任何一种比特帧均可以实现透明传输。
 | PPPoE | 通过配置PPPoE，可以实现与远端设备建立PPP会话，实现接入控制和计费。
 | 帧中继 | 支持帧中继链路承载IP业务（单链路），帧中继链路承载IP业务（多链路），帧中继链路承载PPP业务（单链路），帧中继链路承载PPP业务（多链路），支持在IP网承载帧中继，帧中继流量整形。
局域网接入 | VLAN | 支持基本VLAN、VLAN Damping、Voice VLAN、VLANIF接口。
 | MAC | 支持静态MAC、动态MAC、MAC limit、Sticky MAC、MAC防漂移、非法MAC告警。
 | STP | 提供STP、RSTP和MSTP功能。
 | WLAN | 提供无线用户接入功能，无线用户可以访问传统局域网，提供集成AC功能。
 | 透明网桥 | 连接多个局域网。
 | 链路聚合 | 提供LACP模式链路聚合和三层链路聚合。
IP应用 | ARP | 提供以太网的IP解析服务。
 | IPv4/IPv6 | 提供IP地址管理、TCP/UDP Socket服务、ICMP协议、Ping/Tracert工具以及UDP Helper等功能服务。支持IPv4和IPv6。
 | DNS | 提供域名解析服务，包括DNS Client、DNS Proxy以及DDNS Client服务。支持IPv4和IPv6。
 | DHCP | 提供DHCP的动态地址服务，包括DHCP Client、DHCP Relay、DHCP Server功能，同时对DHCP服务进行安全控制。支持IPv4和IPv6。
 | NAT | 将私有（保留）地址转化为合法IP地址。
 | IPv6过渡 | 支持IPv4 over IPv6、IPv6 over IPv4。
IP路由 | 路由策略 | 基础路由功能。
 | 策略路由 | 提供IP单播策略路由。
 | IPv4/IPv6静态路由 | 基础路由功能。
 | RIP/RIPng | 基础路由协议。
 | OSPF/OSPFv3 | 基础路由协议。
 | ISIS/ISISv6 | 基础路由协议。
 | BGP/BGP4+ | 基础路由协议。
组播 | 组播路由 | 提供基础的组播路由管理、组播路由的负载分担。
 | IGMP | 提供IGMP基本功能。
 | PIM(IPv4) | 提供PIM-DM和PIM-SM功能。
 | MSDP | 提供跨域（PIM-SM域）组播的组播路由功能。
MPLS | 静态LSP | 提供静态LSP功能。
 | MPLS LDP | 提供MPLS LDP功能。
 | MPLS TE | 支持MPLS TE基础和MPLS TE可靠性。
QoS | MQC | 提供模块化的流量分类策略。
 | 优先级映射 | 提供802.1P、DSCP和EXP优先级之间的映射功能。
 | 流量监管 | 提供基于流分类、端口的流量监管。
 | 流量整形 | 提供基于流分类、端口的流量整形，支持自适应整形。
 | 拥塞管理 | 提供基于流分类、端口的拥塞管理。
 | 拥塞避免 | 提供基于流分类、端口的拥塞管理。
 | HQoS | 提供基于多级队列的层次化调度，不仅区分了业务，也区分了用户。
 | 基于ACL的简化流策略 | 配置基于ACL的简化流策略，对匹配ACL规则的报文进行过滤。
安全 | ACL | 提供基本ACL、高级ACL、基本ACL6、高级ACL6、二层ACL功能。
 | AAA | 提供认证、授权、计费三种安全功能。
 | Firewall | 支持ACL包过滤和ASPF。
 | NAC | 支持802.1x、MAC认证、内置Portal认证。
 | DHCP Snooping | 支持DHCP Snooping。
 | IPSG | 对接收到的IP报文进行绑定表匹配检查，有效的防止基于源地址欺骗的网络攻击行为。
 | 本机防攻击 | 支持CPU防攻击、攻击溯源。
VPN | L3VPN | 提供基于BGP的L3VPN互联功能。
 | GRE | 提供GRE基本功能。
 | IPSec | 为IP数据包提供了高质量的、可互操作的、基于密码学的安全性。
 | DSVPN | 支持在Hub-Spoke网络模型中，分支与总部、分支与分支间动态建立VPN。
 | L2TP | 二层隧道协议，虚拟私有拨号网VPDN（Virtual Private Dial-up Network）隧道协议的一种，是远程拨号用户接入企业总部网络的一种重要VPN技术。
可靠性 | 接口备份 | 支持接口备份与NQA联动、接口备份与BFD联动、接口备份与路由联动。
 | BFD | 支持单跳和多跳BFD。
 | VRRP | 为IP服务提供一个冗余选择备份的机制。
网络管理 | SNMP | 提供SNMP代理、FM（Fault Management，故障管理）和TSC（告警开关控制）功能。
 | LLDP | 标准的二层信息交流协议，提供了一种标准的链路层发现方式。
 | NTP | 提供传统的IP网络时间同步功能。
 | 镜像 | 将报文复制到特定的目的地进行分析，以进行网络监控和故障排除，提供本地端口镜像、远程端口镜像、本地流镜像、远程流镜像。
 | NetStream | 提供对网络中的业务流量情况进行统计和分析功能。
父主题： 设备特性列表


WLAN设备

阅读本章有助于您了解WLAN设备支持的特性。

模拟WLAN设备支持的特性如表1和表2所示。

表1 交换转发功能特性列表

特性

子特性

描述

以太网特性

Ethernet
  • 支持链路聚合
  • 支持Trunk内各链路流量的负载分担
  • 支持接口隔离、接口转发限制
  • 支持广播风暴抑制

VLAN
  • 支持Access、Trunk、Hybrid接入方式
  • 支持Default VLAN

MAC
  • 支持MAC地址自动学习和老化
  • 支持静态、动态、黑洞MAC表项
  • 支持源MAC地址过滤
  • 支持接口MAC地址学习限制

ARP
  • 支持静态、动态ARP
  • 支持VLAN上应用ARP
  • 支持ARP表项老化

LLDP
  • 支持LLDP

以太网环路保护

MSTP
  • 支持STP
  • 支持RSTP
  • 支持MSTP

IPv4转发

IPV4特性
  • ARP/RARP
  • ARP代理

单播路由特性
  • 静态路由
  • RIP-1/RIP-2
  • OSPF
  • BGP
  • IS-IS
  • 路由策略、策略路由
  • URPF检查
  • 支持DHCP Client/Server/Relay
  • 支持DHCP Snooping

组播路由特性
  • IGMPv1/v2/v3
  • PIM-SM
  • 组播路由策略
  • RPF

设备可靠性

BFD
  • BFD

二层组播特性

二层组播特性
  • 支持IGMP Snooping功能
  • 支持组播流量控制

QoS特性

流分类
  • 支持基于L2协议头、IP五元组、802.1p优先级的组合流分类

流动作
  • 支持对分类后报文流的访问控制
  • 支持基于流分类的流量监管
  • 支持按照分类结果重标记报文
  • 支持分类后报文进入指定调度队列中
  • 支持流分类、流行为的组合应用

配置与维护

终端服务
  • 支持命令行配置
  • 支持英文提示和帮助信息
  • 支持Console、Telnet终端服务

文件系统
  • 支持文件系统
  • 支持目录和文件管理
  • 支持通过FTP、TFTP方式上传、下载文件

安全和管理

系统安全
  • 命令行分级保护、未授权用户无法侵入设备
  • 支持SSHv2.0
  • 支持RADIUS和HWTACACS用户登录认证
  • 支持ACL过滤

网络管理
  • 支持ICMP实现Ping和Traceroute功能
  • 支持标准网管协议SNMPv1/v2c/v3
  • 支持通用特性的标准MIB
表2 无线组网能力

特性

描述

AP与AC间组网方式
  • 支持AP与AC之间为L2层网络拓扑
  • 支持AP与AC之间为L3层网络拓扑
  • 支持AC直挂AP
  • 支持WDS功能

转发模式
  • 支持直接转发（又称分布转发或本地转发）
  • 支持隧道转发（又称集中转发）
  • 支持集中认证、分布转发

支持AC发现机制
  • AP获取AC IP的方式有：

    以DHCP Option43方式获取

  • AC以DHCP方式为AP分配管理IP
  • 支持DHCP Relay
  • 在二层网络中，支持CAPWAP协议的广播方式发现AC

CAPWAP隧道
  • 支持集中式CAPWAP
  • 支持CAPWAP控制隧道和数据隧道，数据隧道为可选配置
  • 支持基于ESS配置的转发方式（即隧道转发或直接转发）
  • 支持CAPWAP隧道心跳检测，断链重建

支持主备AC
  • 支持回切使能控制
  • 支持1+1热备方式

AP设备的接入控制
  • 支持基于MAC或SN的AP白名单功能的设置和查询
  • 支持以单个和批量（MAC地址段或SN段）方式手动设置白名单
  • 支持半自动上线（手工确认）接入方式
  • 支持全自动（无需认证）AP接入

AP域管理
  • 支持设置AP域的布放类型
  • 支持指定域设置为默认域，用于配置AP自动上线

AP配置模板管理
  • 支持指定某AP配置模板为默认模板，用于配置AP自动上线

服务集（ESS）管理
  • 支持基于ESS的AP二层隔离
  • 支持基于ESS的映射业务VLAN
  • 支持基于ESS关联安全等业务模板
  • 支持基于ESS控制AP组播开关

基于VAP的业务管理
  • 支持VAP的批量创建及绑定射频 ESS
  • 支持按多种方式查询VAP：单个查询、按ESS查询、批量查询
  • 支持业务离线配置
  • AP全自动上线方式下，根据业务批量发放规则，自动创建VAP

配置的自动发放管理
  • 支持基于“AP类型+射频ID”定义业务配置的自动发放规则
  • 支持自动上线AP加入缺省域（缺省域可事先制定）
  • 自动发放规则与域配合使用，实现针对某区域AP的批量上线

无线用户地址分配

集成DHCP服务器，为无线用户分配地址

WLAN用户管理
  • 支持用户黑白名单
  • 支持用户接入数量限制：

    按AP限制用户接入数量，按SSID限制用户接入数量

  • 支持多种查询方式：

    支持基于用户MAC、AP、射频、WLAN ID方式查询用户状态信息，支持按ESS、AP、射频查询在线用户数

WLAN用户漫游
  • 支持AC内的二层漫游
说明：

用户可经AP从AC相同或不同物理口接入。

  • 支持AC内的跨VLAN的三层漫游
  • 支持用户信息的延时清除，实现用户下线后的快速重新上线

用户组管理
  • 支持基于用户组的ACL访问控制
  • 支持基于用户组的隔离

    支持组间隔离，支持组内隔离

WLAN安全模板管理
  • 支持通过WLAN安全模板管理认证和加密方式
  • 支持安全模板绑定到ESS模板

支持多种认证
  • 支持“OPEN-SYS认证+无加密”方式（模拟实现，与真实设备不同）
  • 支持WEP的认证/加密方式（模拟实现，与真实设备不同）
  • 支持WPA/WPA2认证加密（模拟实现，与真实设备不同）

    WPA/WPA2-PSK+TKIP、WPA/WPA2-PSK+CCMP、WPA/WPA2-802.1x+TKIP、WPA/WPA2-802.1x+CCMP

  • 支持MAC组合认证

    将用户MAC地址做账号，送认证服务器（Radius Server）认证

支持组合认证
  • 支持MAC组合认证

    PSK&MAC认证

AAA
  • 支持本地认证/本地账户（MAC、账号）
  • 支持Radius认证
  • 支持多认证服务器

    支持备份认证服务器、基于账号域指定认证服务器、基于账号域配置认证服务器、支持用户账号域与SSID绑定

安全隔离
  • 支持基于端口的隔离
  • 支持基于用户组的隔离

权限控制
  • 支持基于端口的ACL权限控制
  • 支持基于用户组的ACL权限控制
  • 支持基于用户的ACL权限控制

敏捷分布式WLAN组网

(包括AC+中心AP+RRU )
  • 支持AD直挂多个RRU的组网。
说明：

RRU的业务VLAN目前只支持vlanid为1。
父主题： 设备特性列表


防火墙

阅读本章有助于您了解防火墙支持的特性。

模拟USG5500防火墙支持的特性如表1所示。

模拟USG6000v防火墙支持的特性如表2所示。

说明：

防火墙USG5500仿真设备只做保留，不再维护。

表1 USG5500防火墙支持的特性

特性

子特性

描述

防火墙

公共对象

公共对象包括地址集、时间段和服务集，用于被ACL和安全策略等特性引用，便于集中规划并提高复用率

安全区域

一个安全区域是若干接口所连网络的集合，这些网络中的用户具有相同的安全属性

ACL

设备实现流量控制的重要手段，它可以应用到包过滤、IPSec、QoS（Qulity of Service）、路由策略等功能中

安全策略

按一定规则检查数据流是否可以通过防火墙的基本安全控制机制

NAT

一种IP地址转换技术，通过NAT可以将IP报头中的IP地址转换为另一个IP地址

ASPF

针对应用层的包过滤，即基于状态的报文过滤

IP业务

IP基础

支持配置IP地址、静态ARP

DNS
  • 支持DNS解析
  • 支持DNS Proxy

DHCP
  • 支持DHCP客户端
  • 支持DHCP服务器
  • 支持DHCP中继

IP路由

OSPF

一种基于链路状态的路由协议

RIP

一种基于距离矢量（Distance-Vector）算法的路由协议

静态路由

一种特殊的路由，它由网络操作人员手工输入到设备的配置信息中

接入

链路聚合

支持手工链路聚合

vlan
  • 支持基础vlan
  • 支持vlanif

MPLS和VPN

IPSec
  • 支持手工方式创建IPSec SA
  • 支持IKE协商创建IPSec SA

GRE

支持创建Tunnel接口，在Tunnel接口上进行功能特性的配置

配置与维护

文件系统
  • 支持通过FTP、TFTP方式上传、下载文件
  • 支持Telnet

表2 USG6000V防火墙支持的特性
特性 | 子特性 | 说明
内容安全 | 应用识别 | 通过预先搭载的特征库识别常见应用程序。
 |  | 特征库可得到持续更新，同时还支持自定义应用程序。
 |  | 支持对数十种常见的承载协议进行协议解码，识别协议内容。支持常见的多通道协议。
 | SSL加密流量检测 | 支持对SSL流量进行解密，确定其真实的流量后，进行内容安全检测。
 | 反病毒 | 利用专业的智能感知引擎和不断更新的病毒特征库实现对病毒的检测和处理。
 | 入侵防御 | 支持对数千种常见的入侵行为、蠕虫、木马、僵尸网络、恶意域名进行检测和防护。
 |  | 特征库可得到持续更新，同时还支持自定义签名。
 | URL过滤 | 支持根据HTTP协议中的URL地址对连接进行阻断。
 |  | 支持本地添加URL和URL分类、向远程URL查询服务器实时查询最新的URL及其所属分类。
 |  | URL分类可得到持续更新。
 | DNS过滤 | 支持在域名解析阶段过滤DNS请求中的域名，从而控制运行或进行访问的网站。
 | 内容过滤 | 支持HTTP、FTP、SMTP、POP3、NFS、SMB、IMAP、RTMPT和FLASH等常见的文件传输协议。
 |  | 支持对以上协议传输的常见文档文件内容进行基于关键字的过滤。
 |  | 支持对HTTP和FTP的协议内容进行基于关键字的过滤。
 | 文件过滤 | 支持HTTP、FTP、SMTP、POP3、NFS、SMB、IMAP、RTMPT和FLASH等常见的文件传输协议。
 |  | 支持对以上协议传输的常见文档文件、代码文件、可执行文件、多媒体文件、压缩包文件的真实类型和扩展名的识别。
 |  | 支持对以上协议传输的常见文件进行基于真实类型和扩展名的过滤。
 | 应用行为控制 | 支持对HTTP协议的文件上传下载、POST、浏览网页、HTTP代理等应用行为进行控制。
 | 邮件过滤 | 支持本地建立邮件服务器黑白名单，对垃圾邮件服务器进行阻断。
 |  | 支持根据邮件的收/发件人地址、附件大小/个数等信息对邮件进行过滤。
 | APT防御 | 支持通过与沙箱联动对APT攻击进行检测和防御。
网络层安全防护 | 包过滤 | 支持基于策略的包过滤。
 | NAT | 支持对报文源、目的IP地址和端口进行转换。
 |  | 支持将私网IP地址和端口映射为公网IP地址和端口，使内网服务器可以对外提供网络服务。
 |  | 支持对多通道协议报文的载荷中协商的IP地址和端口进行自动转换。
 | CGN | 支持NAT444，在用户网关侧和运营商出口处部署两次NAT功能。
 |  | 支持PCP，使基于P2P技术的文件共享、语音通信、视频传输等业务可以在NAT444场景中很好地运行。
 |  | 支持静态映射，在NAT444场景中解决用户地址的快速溯源。
 |  | 支持DS-Lite，通过隧道和NAT结合，解决私网IPv4用户跨越IPv6网访问IPv4 Internet的问题。
 |  | 支持端口预分配和增量分配，在NAT转换前预先为用户分配端口段，后续从此用户来的业务都用此端口段的端口进行处理。
 |  | 支持NAT64，解决IPv4网络和IPv6网络互访的问题。
 | 单包攻击防范 | 防范多种单包攻击，进行文合法性检查：IP Spoofing、LAND攻击、Smurf攻击、Fraggle攻击、WinNuke、Ping of Death、Tear Drop、地址扫描、端口扫描、IP Option控制、IP分片报文控制、TCP标记合法性检查、ICMP报文控制、ICMP重定向报文控制、ICMP不可达报文控制、TRACERT报文控制。
 | 黑名单 | 支持通过基于IP地址的黑名单，对报文进行快速过滤。
 | 白名单 | 支持通过基于IP地址的白名单，直接跳过黑名单、内容安全和攻击防范处理流程。
 | IP与MAC地址绑定 | 支持将用户主机的IP地址与MAC地址进行绑定，防范IP地址仿冒。
 | SCTP | 支持配置SCTP NAT。
流量管理 | 基于IP和用户的带宽管理 | 可以限制IP或用户的最大带宽。
 | 基于IP和用户的连接数管理 | 可以限制IP或用户的最大连接数。
 | 基于接口的带宽管理 | 可以限制接口的最大带宽。
智能选路 | DNS透明代理 | 支持修改DNS请求报文的目的地址，将DNS请求分发到不同的ISP，以实现流量负载分担。
 | 策略路由 | 支持从应用、服务、用户、入接口、源安全区域、源/目的IP地址、时间段等维度决定如何转发报文。
 |  | 支持单出口和多出口，当策略路由为多出口时，可以基于链路带宽、链路权重、链路质量或链路优先级进行智能选路。
 | 全局选路策略 | 支持基于等价路由的智能选路，可以根据链路带宽、链路权重、链路质量或链路优先级进行选路。
 | ISP选路 | 支持基于目的地址所在运营商网络选择相应的出接口。
 | 健康检查 | 支持基于多种协议对服务或链路的可用性进行探测。
负载均衡 | 服务器负载均衡 | 支持简单轮询、加权轮询、加权源IP hash等算法，和会话保持技术。
 | SSL卸载 | 支持HTTPS协议的SSL卸载。
路由交换与报文转发 | 交换协议 | 支持ARP、VLAN、PPP/PPPoE等常用链路层协议。
 | 路由协议 | 支持静态路由、策略路由、路由策略、RIP、IS-IS、OSPF、BGP、组播等常用路由协议。
 | IP转发 | 支持DNS、DHCP、ICMP、URPF等基本IP协议。
IPv6 | IPv6基础技术 | 支持IPv6报文的解析与转发，支持IPv6的静态路由、策略路由、路由策略以及RIPng、OSPFv3、BGP4+、IS-ISv6等IPv6动态路由协议。
 | IPv6过渡技术 | 支持4to6、6to4、NAT64等IPv6过渡技术，可以组建完整的IPv6网络，以及作为IPv6网络和IPv4网络的边界。
 | IPv6网络的安全防护 | 支持基于IPv6地址部署安全策略，进行IPv6网络的安全防护。可以基于IPv6地址对网络主机的报文进行包过滤和内容安全的检测处理，所能实现的功能和达到的防护效果与IPv4一致。
VPN | IPSec/IKE | 支持IKE的v1和v2两个版本。
 |  | 支持DES、3DES、AES等多种加密算法，支持MD5、SHA1等多种校验算法。提供完整的报文加密与验证能力。
 |  | 支持L2TP over IPSec、GRE over IPSec。
 | L2TP | 支持作为LAC或者LNS。
 | GRE | 支持通过GRE跨网传播RIP、OSPF和BGP。
 | SSL VPN | 支持Web代理、网络扩展、端口转发、文件共享。
 | MPLS | 支持MPLS L3VPN。
 |  | 支持L2TP、IPSec、GRE接入MPLS VPN功能。
 |  | 支持MPLS承载IPSec VPN功能。
高可靠性 | 双机热备 | 支持VRRP、VGMP、HRP等双机热备协议。提供完善的双机热备处理机制，保证主机发生故障时，业务可以自动平滑切换到备机上运行。
 | 链路状态检测 | 支持通过ICMP探测、ARP探测、BFD等方式对链路连接状况进行实时检测，在链路故障时及时倒换流量。
虚拟系统 | 功能虚拟化 | 除硬件资源、网络资源等需要集中管理的资源外，实现了主要功能的完全虚拟化。每个虚拟系统都拥有各自的配置、表项以及资源。
 | 虚拟管理员 | 支持创建虚拟管理员，每个管理员可以分配特定虚拟系统。每个管理员都有各自的配置界面，可以独立对设备进行维护操作。不同虚拟系统间相互隔离，配置不会产生冲突。
可视化管理与维护 | 全新设计的Web界面 | 全新设计的Web界面提供了丰富、易用的可视化管理和维护功能，在Web界面可以轻松查看日志报表、进行配置管理和故障诊断。使用Web界面中的快速向导可以轻松完成部分重要特性的常用配置。
 | 多种远程管理方式 | 支持Web、CLI（Console、Telnet、SSH）、网管（SNMP）等多种管理方式。
 | 远程管理 | 支持通过Console口、Telnet、SSH、Web等多种方式登录设备进行管理。
 |  | 支持SNMP协议，可以使用标准网管软件进行管理。
 |  | 支持Syslog格式日志，可以使用日志服务器进行日志收集和管理。
 |  | 支持NQA。
父主题： 设备特性列表


NE

阅读本章有助于您了解NE40E、NE5KE、NE9K、CX设备支持的特性。

模拟NE、CX设备支持的特性如表1所示。

表1 NE\CX支持的特性
零级特性 | 一级特性 | 二级特性 | 三级特性
基础配置 | 远程登录 | IPv4 Telnet Server | -
 |  | IPv4 Telnet Client | -
 |  | IPv6 Telnet Server | -
 |  | IPv6 Telnet Client | -
 | 设备管理 | 端口管理 | -
 |  | 可维护性 | -
 | NAP | - | -
 | 日期时间管理 | 时间查看 | -
 |  | 时间设置 | -
 |  | 时区设置和查询 | -
 |  | 夏令时设置和查询 | -
 | 安全管理 | 可信启动 | -
 |  | 根密钥管理 | -
 | 系统监控 | CPU监控 | -
 |  | 内存监控 | -
 |  | 异常监控 | -
 |  | 消息监控 | -
系统管理 | 命令行接口 | CLI Basis | 支持CliRscM, 命令视图, Command, 命令行输出管道, 命令帮助, 交互命令, 命令鉴权, 批量命令
 |  | MMI | -
 |  | XPL | -
 |  | LSVS | -
 |  | 可维护性 | -
 |  | 可扩展性 | -
 |  | OM接口 | -
 | 配置管理 | CfgM Basis | 支持多种配置工具接入管理, 配置session管理, 分布式多实例
 |  | Config CommitRollback | 支持Commit Immediately, Commit Confirm
 |  | Config Restore | 支持配置恢复基础, LSVS配置恢复, 配置恢复可靠性, 远程配置文件恢复, 增量配置文件恢复, 配置恢复ISSU, 清库保留DCN重启, Config File Management , Startup, DB 翻译
 |  | Offline Config | -
 |  | Config Extension | 支持Data Verify, Compare Configuration, Lock, Database Management
 |  | Maintaining Command | -
 |  | Display Command | -
 |  | Configuration Rollback | 支持Checkpoint, Display Config Changes , Delete Checkpoint, Rollback Configuration, Confirmed Commit配置试运行, CFG INIT ALL, 一键清除接口配置
 |  | BIM | 支持BIM数据库
 |  | TimeRange | -
 |  | 协议报文跟踪 | -
 |  | 资源补丁 | -
 | IM | SysLog | -
 |  | LogType | -
 |  | Debug | -
 |  | 日志多语种补丁 | -
 | License | License Validation | -
 |  | GTL | -
 |  | LicenseM | -
 | Paf | - | -
 | 认证计费授权 | Authen-Admin | -
 |  | Author-Admin | -
 |  | Account-Admin | -
 |  | Public-Admin | -
 |  | Command-Author | -
 |  | Local-Admin | -
 | Radius | - | -
 | HWTacacs | - | -
 | RMON | RMON | -
 | 故障管理 | Alarm Report | -
 |  | Alarm Inquiry | -
 |  | Alarm Relativity | -
 |  | Event Report | -
 |  | Alarm Alarm Shield | -
 |  | Alarm Storage | -
 | 性能管理 | PM Basis | -
 |  | DataStatistic | -
 |  | StatisticFile | -
 |  | StatisticUpload | -
 |  | Threshold | -
 |  | KPI记录 | -
 | DCN | NEID | -
 |  | NEIP | -
 |  | OSPF 相关 | -
 |  | 全局属性 | -
 |  | 接口管理 | -
 |  | VLAN | -
 |  | OSPF LSA代理 | -
 |  | 跨接透传 | -
 |  | 安全相关 | 支持修改QX登陆秘钥, 防暴力攻击, DCN ACL, SSL, GNE与NE通道加密
 |  | 电信DCN | -
网络可靠性 | VRRP | VRRP4 | 支持VRRP主备备份, VRRP负载均衡, VRRP抢占, 分布式VRRP, VRRP认证, Ping虚地址, 免费ARP发送, VRRP Version3, L3VPN私网下的VRRP, VRRP4心跳报文次数设置
 |  | VRRP联动 | 支持VRRP4/VRRP6/单播VRRP Track 接口, VRRP4/VRRP6/单播VRRP Track普通BFD, VRRP4/VRRP6/单播VRRP Track peer-bfd, VRRP4/VRRP6/单播VRRP Track link-bfd, VRRP4 Track 3ah, VRRP4/VRRP6 Track CFM, VRRP和路由监控, VRRP4/VRRP6震荡抑制功能, VRRP4监控NQA检测实例, VRRP4监控IPSEC
 |  | 管理VRRP | 支持管理VRRP与业务VRRP联动, 业务VRRP的Track模式, 管理VRRP忽略shutdown特殊场景, 管理VRRP监控链路BFD阀值, PW Track管理VRRP, 不具网关功能的管理VRRP
 |  | VRRP6 | 支持主备备份, 负载均衡, VRRP6抢占, Ping虚地址使能, ND报文组播发送, VRRP6版本Version3, 管理VRRP6, VRRP6与VRRP4共用规格, VRRP6心跳报文次数设置
 |  | 单播VRRP | 支持单播VRRP认证, 单播VRRP抢占
 |  | 可靠性 | 支持HA, ISSU, BRAS双机热备, 虚拟接入双机热备
 |  | 可维护性 | 支持Log, 诊断, Debugging, Alarm, PAF, CLI, 私有Yang
 |  | LS\VS | -
 | E-Trunk | E-Trunk基本功能 | 支持跨框Eth-Trunk状态控制, 跨框Global-Ve状态控制
 |  | 安全性 | 支持E-Trunk认证
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持Log, 诊断, Debugging, PAF, CLI, 私有Yang
 |  | LS\VS | -
 | MC-LAG | MC-LAG基本功能 | 支持跨框LAG状态控制
 |  | 口字型组网 | -
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持Log, 诊断, Debugging, Alarm, PAF, CLI, 私有Yang
 |  | LS\VS | -
接入与链路 | Ethernet | 以太封装类型 | -
 |  | Ethernet子接口 | 支持vlan接入, vlan+策略接入, Untag+策略接入
 |  | Ethernet子接口支持业务 | -
 |  | LSVS | -
 |  | 配置回退 | -
 | Vlan | vlan-Basic | 支持静态vlan, 动态VLAN, 以太类型值, vlan统计, vlan显示
 |  | vlan-type | 支持按端口划分vlan, 策略匹配优先级, Port Bridge
 |  | vlanif | 支持vlanif三层转发, vlanif stacking, vlan damping, vlanif shutdown, vlanif的业务
 |  | vlan-app | 支持聚合VLAN, MUX-vlan, 管理VLAN, VLAN透传二层协议报文, 二层环路检测
 |  | CF-Cfg | -
 |  | CF-VS | -
 |  | CF-HA | -
 |  | CF-INTF | -
 | GVRP | GVRP基础 | 支持GVRP基本功能
 |  | LR/VR规格 | -
 |  | 可靠性 | -
 |  | 性能 | -
 | MAC | MAC-Basic | 支持MAC表项删除, MAC表项统计, MAC老化, 静态MAC, 动态MAC表项
 |  | Mac-Limit | 支持MAC-limit应用, MAC-limit限制功能, VLAN场景下, VSI场景下, GMAC-Limit
 |  | CF_CFG | -
 |  | LSVS | -
 |  | 可靠性 | -
 |  | 可维护性 | -
 | QinQ | QinQ-Basic | -
 |  | QinQ-Stacking | -
 |  | Dot1q-Terminal | -
 |  | QinQ-terminal | -
 |  | CF-Cfg | -
 |  | CF-HA | -
 | HDLC | HDLC协议基础 | 支持线路有效性检测, 的物理接口, CHDLC连接的数目, HDLC链路层检测环回, KEEPALIVE的配置, HDLC链路状态震荡抑制功能
 |  | HDLC承载业务 | 支持对IPv4报文的封装, 对MPLS报文的封装, 对IPv6报文的封装
 |  | 可靠性 | 支持ISSU
 |  | 可维护性 | 支持CLI
 |  | LR/VR规格 | -
 | PPP | PPP协议基础 | -
 |  | 认证方式 | -
 |  | PPP多链路捆绑 | -
 |  | 业务承载 | -
 |  | MP | -
 |  | DCN | -
 |  | RollBack | -
 | L2TPV3 | L2TPV3协议 | 支持L2TPV3基础配置, 本地交换, 注入隧道, 互通, 三层子接口主隧道, 隧道的源地址采用任意物理子接口地址, 性能规格
 |  | ISSU | -
 |  | CF_CFG | -
 |  | LSVS | -
 |  | 可靠性 | -
 |  | 可维护性 | -
 | FR | 基本功能 | 支持FR协议基础, FR的接口类型, 的接口, FR LMI, 请求报文超时时间, 被观察总数与错误门限, LMI协议和PVC显示, LMI协议报文统计
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | -
 |  | LS/VS | -
 | Eth-Trunk | Basic | 支持二层Eth-Trunk, 三层Eth-Trunk, Eth-Trun子接口, Trunk成员口, Trunk捆绑方式, 显示Eth-Trunk信息, Eth-Trunk接口功能
 |  | Content | 支持负载分担, 成员权重, 链路下限阀值, 最大感知链路带宽, Trunk主备, Eth-Trunk的MAC
 |  | APP | 支持ARP、VRRP等以太协议, isis、ospf、bgp协议和转发, 组播协议和转发, MPLS协议和标签转发, IPv6协议转发, L3VPN业务和转发, L2VPN的接入和转发
 |  | HA | -
 |  | Eth-Trunk RollBack | -
 |  | MAIN | -
 |  | LRVR | -
 | IP-Trunk | Basic | 支持Trunk成员口, Trunk捆绑方式, 显示IP-trunk信息, IP-Trunk接口功能
 |  | Content | 支持负载分担, 成员权重, 链路下限阀值
 |  | APP | 支持isis、ospf、bgp协议和转发, 组播协议和转发, MPLS协议和标签转发, IPv6协议转发, L3VPN业务和转发, L2VPN的接入和转发
 |  | HA | -
 |  | Eth-Trunk RollBack | -
 |  | MAIN | -
 |  | LRVR | -
 | LAG | 功能 | 支持静态负载分担链路聚合, 手工负载分担链路聚合, 静态非负载分担链路聚合, 手工非负载分担链路聚合, 非负载分担恢复模式, LAG负载分担, LAG优先级, LAG属性切换, LAG创建删除, LAG成员口加入退出, VE加入LAG, 静态LAG协议状态, LAG接收业务报文方式, 最小激活链路阈值, 与其他功能结合, LAG容限, lag二阶段配置, 震荡抑制
 |  | 可靠性 | 支持主备倒换, 重启单板, 重启设备, 软复位
 |  | 可维护性 | 支持聚合组告警, 兼容性
 | LACP | lacp基础 | 支持静态lacp协议, selected端口协商选择, lacp参数调整, lacp端口抢占, 动态lacp协议
 |  | lacp应用 | 支持上限阈值配置, M:N备份, 链路下限阀值, 负载分担, 非对称链路检测, lacp报文成环检测, LACP承载业务, 混合带宽捆绑, LACP发布动态ESI信息, LACPVRRP, 系统mac自动协商, force-up
 |  | 可靠性 | 支持震荡抑制, HA
 |  | 可维护性 | 支持lacp显示信息, 协议收发统计, MAIN, RollBack, 告警, 日志
 |  | LR/VR规格 | -
 | LMP | 静态LMP | 支持静态LMP, 静态LMP创建Te-Link, 静态LMP创建Data-Link
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持可以通过命令行查询邻居、Te-Link及DataLink信息
 |  | LS/VS | -
 | MSTP | 基础协议 | 支持STP, RSTP, MSTP
 |  | 应用场景 | 支持多进程, STP over PW, V-STP, STP联动TRILL, STP for EVC
 |  | LR/VR规格 | -
 |  | 可靠性 | 支持HA
 |  | 可维护性 | 支持DEBUG, LOG
 | LLDP | LLDP基础 | 支持LLDP邻居发现, 参数调整, TLV类型, 统计查询, 可靠性测试
 |  | LLDP协议业务扩展 | 支持承载协议信息通告, 统计查询, MDN特性
 |  | 可靠性需求 | 支持HA
 |  | 可维护性需求 | 支持Cfg, LOG, DEBUG
 | Vperception | Neighbor-Discovery | -
 |  | User-Online | 支持虚拟感知, 策略自动部署, 网络管道打通, 策略在线更新, VM获取策略Radius服务器模板配置
 |  | Users-Offline | 支持虚拟感知, TOR删除VM策略, 用户下线通知Radius服务器, 网络管道撤销
 |  | User-Transfer | 支持迁移感知, 策略迁移, 网络管道动态调整, 流量迁移
 |  | 可靠性 | 支持HA, NSR, ISSU, 接口板热插拔, 整机重启
 |  | 可维护性 | 支持事件&告警, 诊断
 |  | LS/VS | -
 | DLDP | DLDP基础 | 支持协议基础, 故障检测, 故障处理, 参数调整, 查询统计
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | -
 |  | LS/VS | -
 | TWAMP | twamp | 支持Server, Reflector
 |  | twamp-light | 支持client, sender, Server, responder
 |  | 可维护性 | 支持PAF, CLI, log, 诊断
 |  | LS/VS | -
 | Smartlink | 基础功能 | 支持配置Smart Link组创建和删除, 配置Smart Link组灵活链路功能使能, 配置Smart Link组主端口和从端口, 链路切换发送Flush报文, 链路切换发送携带密码的Flush报文, 接收Flush报文, 接收携带密码的Flush报文, 查询Smart Link组运行信息, 查询Smart Link组Flush报文统计信息
 |  | 业务功能 | 支持延时回切, 配置延时回切时间, 流量锁定, 手工强制切换, 故障延时通告, 多实例
 |  | 可维护性测试 | -
 |  | 性能测试 | -
 |  | CF-VS | -
 |  | CF-Cfg | -
 | EVC | EVC基础架构 | 支持二层子接口, BD, vBdIf
 |  | E-LAN业务 | -
 |  | EVC三层终结 | -
 |  | CF_CFG | -
 |  | LSVS | -
 |  | 可靠性 | -
 |  | 可维护性 | -
 | ERPS | ERPS协议 | 支持子环模式, 虚通道和非虚通道子环, 强制切换与手动切换, 环间拓扑变化通告, 不回切, 保护清除, V1与V2版本切换, 协议机制, 报文类型, 延时回切, 状态机, eth-type, 报文发送间隔, 主环, 虚通道VLAN列表, 虚通道VLAN交换表, WTB定时器, WTR定时器, holdoff定时器, guard定时器
 |  | 应用场景 | 支持闭合单环, 链路故障检测, 成环检测
 |  | 02_ERPS可靠性 | -
 |  | 03_可维护性 | -
 |  | 04_协议一致性 | -
 |  | 05_安全性 | -
 |  | 06_互通 | -
 |  | 07_框架需求 | -
 | TRILL | 邻居建立 | 支持广播网的邻居建立, 广播网模拟p2p的邻居建立, 端口类型
 |  | LSDB发布和同步 | 支持定时器, INT-VLAN的发布
 |  | 动态主机名 | -
 |  | 路由计算 | 支持L单播路由计算, 组播路由计算
 |  | 认证 | -
 |  | VLAN交互 | -
 |  | AF | -
 |  | 网络业务应用 | 支持带内网管
 |  | 公共机制 | 支持LR/VR, 可维护性, 可靠性(部分支持)
 | SegmentRouting | SR IPv4 MPLS | 支持ISIS for SR(部分支持), OSPFv2 for SR(部分支持), BGP for SR, SR-BE(部分支持), SR-TE(部分支持), 控制器接口, 公共机制(部分支持)
 |  | SRv6 | 支持ISIS for SRv6(部分支持), SRv6-TE(部分支持), 公共机制(部分支持)
 | LAD | 线缆搜索基础 | -
 |  | 邻居发现 | 支持链路邻居查看, 链路邻居清除, 链路邻居搜索, 全局使能/去使能, 发送报文格式差异, 端口使能/去使能
 |  | 可维护性 | 支持DEBUG, LOG
 |  | 可靠性 | 支持HA
 | IFM | IFM状态管理 | 支持物理状态, ipv4协议状态, 二层接入协议状态, ipv6协议状态, BFD与接口联动, BFD trigger if-down, EFM与接口联动, DLDP与接口联动, 接口Down的原因显示, Monitor Link接口联动, 配置Smart Link组灵活链路功能使能, 二层业务状态, shutdown network-layer关闭ipv4和ipv6协议状态功能
 |  | IFM基础功能 | 支持接口创建删除, 接口名帮助, 接口shutdown, MTU分片, 固定索引, 命令互斥与屏蔽, 接口离线显示, IPv4接口信息显示, ipv6接口信息显示, 接口mac, 接口BW
 |  | IFM扩展功能 | 支持接口restart, 接口restart限制, 接口组, 无device.sys进行配置恢复, vlan与主接口资源互斥, interface range, 路由发布, Damping-interface, 精确帮助
 |  | 接口流量统计 | 支持统计收发报文数量和平均速率, 接口流量按v4/v6分别统计, display counters interface查看接口计数, 查看所有以太主接口广播、组播计数值, 逻辑接口的realtime显示, 设定平均速率的统计间隔, 子接口使能流量统计功能, reset接口统计计数, 清除指定CPOS口计数, PM统计, 历史流量统计查询, display remote-interface查询外联接口流量统计功能, 以比特为单位统计报文
 |  | 链路协议状态告警抑制 | 支持抑制参数配置
 |  | V4地址管理 | 支持IP地址配置, 31/32位掩码, 主从地址配置, IPV4地址冲突检测, IP地址借用, ping显示回应报文入接口信息, 接口绑定VPN, 动态RouterID算法, IPv4源地址选择
 |  | V6地址管理 | 支持IPv6地址, ipv6地址冲突检测, ipv6 Mtu, IPv6源策略
 |  | IFM可维护性 | 支持告警, 诊断命令, PAF/License/GTL, 空配置启动内存, PTN换插不同类型单板配置检查, 软复位
 |  | CF-LRVR | 支持主接口分配VR, 子接口分配VR, Pos接口分配VR, VRn中的接口创建, 接口显示, Trunk接口分配VR测试, AM6, 虚拟管理网口ip地址冲突, 端口组模式分配接口, VS独立启动, 监控组与VS交互功能, VRn下全局统计时间间隔和统计批量清除, Global-VE, 端口拆分, damping-interface
 |  | CF-Cfg | 支持预配置
 |  | CF-HA | -
 |  | 标准Yang | -
 | Monitorlink | monitorlink基础 | 支持联动接口, 延时恢复
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持Log, 诊断, Debugging, Alarm, PAF, CLI, 私有Yang
 |  | LS\VS | -
 | RBS | RBS基本功能 | 支持备份通道, 备份策略, 备份服务(部分支持)
 |  | 安全性 | 支持SSL
 |  | 可维护性 | 支持Log, 诊断, Debugging, Alarm, CLI, 私有Yang
 |  | LS\VS | -
 | MonitorGroup | 监控接口状态 | -
 |  | 可维护性 | 支持Log, 诊断, Debugging, Alarm, CLI
 | MEAP | MEAP基础 | -
IP业务 | ARP | ARP表项 | 支持静态ARP表项, 动态ARP表项, 免费ARP
 |  | ARP安全 | 支持ARP动态表项数量限制, 动态ARP学习速率限制, ARP Miss消息处理的限制, ARP严格学习功能, ARP假表项, ARP合法性检查, arp 学习去使能, arp suppress, DAI, arp代理防攻击, 广播域地址冲突检查
 |  | ARP网关代答 | -
 |  | ARP代理 | 支持路由网关代理, Vlan内代理, SuperVlan的Vlan间代理, QinQ/Dot1q终结子接口的Vlan间代理, ARP二层代理
 |  | ARP支持业务 | 支持ARP PW双发, VLL以太异种介质互联ARP学习, L3VPN私网的arp相关功能, VLINK, ARP探测
 |  | 可靠性 | 支持HA, ISSU, ARP扫描和固化功能, ARP双机热备
 |  | 可维护性 | 支持Log, 诊断, Debugging, Alarm, ARP查询与统计, PAF, CLI, 私有Yang
 |  | LS\VS | -
 | HostRcvSnd | TCP4 | -
 |  | UDP4 | -
 |  | ICMP4 | -
 |  | IPv4 LocalRcvSnd | -
 |  | IPv4 PMTU | -
 |  | TCP6 | -
 |  | UDP6 | -
 |  | IPv6 HostRcvSnd | -
 | LDM | Capture | -
 |  | Statistics | -
 |  | MaDefend | -
 |  | Priority | -
 |  | Packet | -
 |  | AutoDefend | -
 |  | AttackTrace | -
 |  | MPAC | -
 | IPV6协议栈 | SMA | 支持Basic
 |  | Tnl6 | 支持6over4
 |  | ND | 支持RS_RA, NUD_AR, DAD, SECU, REDIRECT, VLINK
 |  | PP6 | 支持ICMPv6, Ext_header, PMTU, Fragment
 | GRE | GRE隧道基础 | 支持GRE IPV4(部分支持), GRE IPV6(部分支持)
 |  | GRE承载业务 | 支持IPV4, IPV6, 三层VPN, GRE group, Soft-GRE, GRE over IPSEC
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持PAF/License, CLI, 诊断
 |  | LR/VR | -
 | DNS | DNS4 | 支持Client
 |  | DNS6
 | DHCP | DHCPv4 Server | 支持DHCPv4 Server协议流程, DHCPv4 Server业务功能, 可维护性, 可靠性
 |  | DHCPv4 Relay | 支持DHCPv4 Relay协议流程, DHCPv4 Relay业务功能, DHCPv4 Relay业务场景, 可靠性, 可维护性
 |  | DHCPv6公共 | 支持设备的DUID, 全局DHCPv6使能, 接口DHCPv6使能, 全局DHCPv6报文限速
 |  | DHCPv6 Server | 支持DHCPv6 Server协议流程, DHCPv6 Server业务功能, 可靠性, 可维护性
 |  | DHCPv6 Relay | 支持DHCPv6 Relay协议流程, DHCPv6 Relay业务功能, DHCPv6 Relay业务场景, 可靠性, 可维护性
 |  | 接入用户DHCP报文收发 | 支持接入用户DHCPv4报文收发, 接入用户DHCPv4抑制, 接入用户DHCPv6报文收发
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持PAF/License, CLI, 诊断
 |  | LR/VR | -
 | DHCP Snooping | DHCP Snooping业务功能 | 支持配置使能, 绑定表管理, 绑定表扩展应用, Option82格式配置
 |  | 可靠性 | 支持重启后动态绑定表恢复, HA, ISSU
 |  | 可维护性 | 支持告警, 绑定表查询, 报文统计查询, PAF/License, CLI, 诊断
 |  | LR/VR | -
 | PNP | DHCPv4 PNP | 支持DHCPv4 PNP功能启动, DHCPv4 PNP功能运行, DHCPv4 PNP功能停止
 | 802.1X | 802.1X基础 | 支持基于MAC的802.1X认证, 基于端口的802.1X认证, 802.1X端口自动授权模式, 802.1X强制授权模式, 802.1X强制不授权模式, 认证等待EAP客户端回应的超时与重传, 802.1x的接口类型, EAPOL终结认证, 802.1X定时握手功能, 802.1X重认证功能, 802.1X绑定认证域认证, EAPOL中继认证, 802.1X端口最大用户接入用户数目, 认证服务器EAP回应报文的超时, 设备主动发送组播报文触发用户认证, 通过单播请求触发用户认证
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持PAF/License, CLI, 诊断
 |  | LR/VR | -
 | NetStream | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持PAF/License, CLI, 诊断
 |  | LR/VR | -
二层业务 | L2Multicast | IGMP SNOOPING OVER VLAN | 支持IGMP SNP 基本功能, IGMP SNP 静态端口, IGMP SNP SSM-MAPPING, IGMP SNP Proxy, IGMP SNP策略, mvlan, 组播instance, IGMP SNP联动拓扑变化快速收敛, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | IGMP SNOOPING OVER VSI | 支持IGMP SNP Martini VPLS, IGMP SNP Kompella VPLS, IGMP SNP 静态端口, IGMP SNP SSM-MAPPING, IGMP SNP Proxy, IGMP SNP策略, IGMP SNP接入接口(部分支持), 组播instance, AC隔离, 主备PW保护, PW over TE/LDP快速切换, IGMP SNP over P2MP VPLS, IGMP SNP over P2MP VPLS 双根1+1保护, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | MLD SNOOPING OVER VLAN | 支持MLD SNP 基本功能, MLD SNP 静态端口, MLD SNP SSM-MAPPING, MLD SNP Proxy, MLD SNP策略, MLD SNP联动拓扑变化快速收敛, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | MLD SNOOPING OVER VSI | 支持MLD SNP Martini VPLS, MLD SNP 静态端口, MLD SNP SSM-MAPPING, MLD SNP Proxy, MLD SNP策略, MLD SNP接入接口(部分支持), AC隔离, 主备PW保护, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | IGMP SNOOPING OVER EVC | 支持IGMP SNP 基本功能, IGMP SNP 静态端口, IGMP SNP SSM-MAPPING, IGMP SNP Proxy, IGMP SNP策略, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | IGMP SNOOPING OVER ELAN | 支持IGMP SNP 基本功能, IGMP SNP 静态端口, IGMP SNP SSM-MAPPING, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | IGMP SNOOPING OVER ETREE
 |  | CAC | 支持CAC基本功能, CAC限制维度(部分支持), CAC计数显示, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 | DHCP PNP | DHCP PNPv4 | -
 |  | DHCP PNPv6 | -
 | L2PT | L2PT基础 | 支持BPDU-Tunnel, l2Protocol-tunnel
 |  | CF_CFG | -
 |  | LSVS | -
 |  | 可靠性 | -
 |  | 可维护性 | -
单播路由 | OSPFv2 | OSPFv2 Basic | 支持LSDB SYNC&NBR, Route Calculate, Route Filter, Route Aggregation, Default Route, route import
 |  | OSPFv2 overflow | -
 |  | OSPFv2 Vlink | -
 |  | OSPFv2 Stub Area | -
 |  | OSPFv2 NSSA Area | -
 |  | OSPFv2 FRR | 支持LFA, RLFA, FRR防微环, Multi Source FRR
 |  | BFD for OSPFv2 | -
 |  | OSPF v2 SR扩展 | -
 |  | OSPFv2 Security | 支持Packet Authentication
 |  | OSPFv2 Multi-Processes | -
 |  | OSPFv2 VRF-Instances | 支持Protect Loop, shamlink, Multi-CE
 |  | OSPFv2 LOCAL MT | -
 |  | OSPFv2 TE扩展 | 支持TE属性 发布, OSPF Shortcut, OSPF FA, Passive TE 发布
 |  | OSPFv2 stub-router | 支持OSPF BGP Synchronization, OSPF stub-router
 |  | OSPFv2 TOPO Advertise | 支持OSPF BGP-LS
 |  | OSPFv2 LDP extend | 支持OSPF-LDP Synchronization, LDP auto-config
 |  | OSPFv2 VRRP | -
 |  | OSPFv2 Hostname | -
 |  | OSPFv2 DCN | -
 |  | OSPFv2 Purge Source | 支持OSPFv2部分Purge溯源, OSPFv2完整Purge溯源
 |  | OSPFv2 multi-area adjacency | -
 |  | 公共机制 | 支持LR/VR, 可维护性, 可靠性(部分支持)
 | OSPFv3 | OSPFv3 Basic | 支持LSDB SYNC&NBR, Route Calculate, Route Filter, Route Aggregation, Default Route, route import
 |  | OSPFv3 Stub Area | -
 |  | OSPFv3 NSSA Area | -
 |  | OSPFv3 FRR | 支持LFA, RLFA, Multi Source FRR, FRR 防微环
 |  | OSPFv3 Security | 支持Packet Authentication
 |  | OSPFv3 Multi-Processes | -
 |  | OSPFv3 VRF-Instances | 支持Protect Loop, Multi-CE
 |  | OSPFv3 stub-router | 支持OSPF BGP Synchronization, OSPF stub-router
 |  | OSPFv3 Hostname | -
 |  | OSPFv3 Purge Source | 支持OSPFv3 部分溯源, OSPFv3完整溯源
 |  | 公共机制 | 支持可维护性, 可靠性(部分支持)
 | ISIS | ISIS Basis | 支持邻居建立和LSDB的同步、扩散, ISIS FlashFlood, 路由计算, 路由引入, 路由聚合, 缺省路由, ISIS Route Leak, ISIS Intellegent Timer
 |  | ISIS Host Name | -
 |  | ISIS Security | 支持Packet Authentication
 |  | ISIS overload | 支持set-overload, ISIS-BGP Synchronization
 |  | ISIS 拓扑上报 | 支持ISIS for BGP-LS
 |  | ISIS LDP extend | 支持LDP Synchronization, LDP auto-config
 |  | ISIS Multi-Processes | -
 |  | ISIS VRF-Instances | -
 |  | ISIS TE扩展 | 支持TE属性发布, ISIS Shortcut, ISIS FA, ISIS Local-MT
 |  | ISIS MT | -
 |  | BFD for ISIS | -
 |  | ISIS FRR | 支持LFA, RLFA, FRR防微环, 多源FRR
 |  | ISIS VC扩展 | -
 |  | ISIS V6 | 支持邻居建立, 路由引入, 路由聚合, 缺省路由, 路由渗透, IPV6 VPN
 |  | ISIS Purge Source | 支持ISIS部分Purge溯源, ISIS完整Purge溯源
 |  | 公共机制 | 支持LR/VR, 可维护性, 可靠性(部分支持)
 | RIP | RIP BASIS | 支持路由引入, 路由接收/发布, 路由过滤, RIP优先级, RIP路由聚合
 |  | RIP Authentication | 支持Simple认证, MD5 IETF认证, MD5 MD5 Huawei认证, MD5 keychain认证
 |  | RIP Multi-Processes | -
 |  | RIP VRF-Instances | -
 |  | BFD FOR RIP | 支持BFD FOR RIP, 单臂bfd for rip
 |  | 公共机制 | 支持LR/VR, 可维护性, 可靠性(部分支持)
 | BMP | session建立 | 支持会话, 安全认证
 |  | 信息监控 | 支持学习路由, 本地路由, 发布路由, 路由统计, 邻居状态
 | RPKI | session建立 | 支持会话, 安全认证
 | BGP | BGP Basis | 支持Neighbor Establish, Peer Group, Confederation, BGP Shutdown, 路由处理
 |  | BGP Extension | 支持peer分布式, 多实例, ADD-PATH, BGP ORF
 |  | BGP Security | 支持Neighbor Security(部分支持)
 |  | BGP Convergence | 支持ebgp-interface-sensitive, BGP Indirection nexthop, Update Group, BGP FRR, BFD for BGP
 |  | BGP Reliability | 支持BGP NSR, GR Reset, BGP ISSU
 |  | BGP Routing Family | 支持IPv4 Unicast(部分支持), IPv6 Unicast(部分支持), IPv4 Unicast Label Route, IPv4 labeled-unicast, 6PE/IPv6 labeled-unicast
 |  | BGP L3VPN Family | 支持IPv4 VPN-instance(部分支持), IPv4 VPNv4, IPv6 VPN-instance(部分支持), IPv6 VPNv6, Route-Target Family
 |  | BGP Mcast Family | 支持IPv4 Muticast, VPNv4 Multicast, IPv4 MVPN, IPv4 MDT, IPv6 MVPN
 |  | BGP L2VPN Family | 支持L2VPN-AD, L2VPN, VPLS
 |  | BGP Extension Family | 支持FlowSpec IPv4(部分支持), FlowSpec IPv6(部分支持), FlowSpec VPNv4, FlowSpec VPNv6, BGP-LS
 | 静态路由 | 公网IPv4静态路由 | 支持StaticRt Basic, StaticRt Extension(部分支持), StaticRt Reliability(部分支持), 静态路由联动
 |  | 私网IPv4静态路由
 |  | 公网IPv6静态路由 | 支持StaticRt Basic, StaticRt Extension, StaticRt Reliability(部分支持), 静态路由联动
 |  | 私网IPv6静态路由
 |  | 公网IPv4组播静态路由 | 支持StaticRt Basic, StaticRt Extension, StaticRt Reliability(部分支持)
 |  | 私网IPv4组播静态路由
 |  | 公网IPV4直连路由 | 支持DirectRt Basic, DirectRt Extension(部分支持), DirectRt Reliability(部分支持), 直连路由联动
 |  | 私网IPV4直连路由
 |  | 公网IPV6直连路由 | 支持DirectRt Basic, DirectRt Extension, DirectRt Reliability(部分支持), 直连路由联动
 |  | 私网IPV6直连路由
 | RM | 公网IPv4路由管理 | 支持RM Basic, RM Extension(部分支持), RM Reliability(部分支持)
 |  | 私网IPv4路由管理
 |  | 公网IPv6路由管理 | 支持RM Basic, RM Extension, RM Reliability(部分支持)
 |  | 私网IPv6路由管理
 | TNLM | 隧道类型 | 支持LSP, CR-LSP, GRE, IP隧道, MPLS Local Ifnet, BGP LSP, GRE IPV6
 |  | 隧道策略 | 支持select-sequence, tunnel-binding
 |  | 隧道选择器 | -
 |  | TNLM Reliability | 支持RM NSR, RM ISSU
 | RTP | RoutePolicy | 支持路由过滤, 路由策略, 可靠性
 |  | XPL | 支持Mechanism, Condition, Action, Policy Match, 可靠性
 | StaicL3VPN | IPv4静态L3VPN | 支持Staic L3VPN Basic, Staic L3VPN Reliability(部分支持)
 |  | IPv6静态L3VPN
 | GRESM | 资源分配 | -
 |  | 资源平滑 | -
 |  | 资源对账 | -
 |  | 可靠性 | 支持NSR, ISSU
 |  | 可维护性 | -
 | OPR | 公网IPv4 OPR | 支持路由下发, 路由迭代, 路由选路, 负载分担
 |  | 私网IPv4 OPR
组播路由 | L3_MCAST | IGMP | 支持IGMPv1, IGMPv2, IGMPv3, IGMP SSM-Mapping, IGMP三层按需转发(部分支持), IGMP 多实例, IGMP policy, IGMP Ipsec, IGMP Limit, IGMP on-demand, IGMP报文统计, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | MLD | 支持MLDv1, MLDv2, MLD SSM-Mapping, MLD 多实例, MLD policy, MLD Ipsec, MLD on-demond, MLD 报文统计, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | StaticGroup | 支持静态组/源组, QinQ/Dot1q终结静态组/源组
 |  | PIM SM | 支持Dynamic BSR, Static RP, Auto RP, Embedded-RP, Admin-scope BSR, RP Group Mapping, PIM SM Base Protocol, BFD for PIM, PIM Silent, DR Switch Delay, Policy For PIM SM, LoadingSplitting, Multicast on multi－topology, PIM IPSEC, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | PIM SSM | 支持PIM SSM Base Protocol, BFD for PIM, PIM Silent, DR Switch Delay, Policy For PIM SSM, LoadingSplitting, PIM SSM多实例, Multicast on multi－topology, PIM IPSEC, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | BIDIR PIM | 支持Dynamic BSR, Static RP, Auto RP, Embedded-RP, Admin-scope BSR, RP Group Mapping, BIDIR PIM Base Protocol, BFD for PIM, PIM Silent, Policy For BIDIR PIM, LoadingSplitting, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | PIM DM | 支持PIM DM Base Protocol, PIM Silent, Policy For PIM DM, LoadingSplitting, Multicast on multi－topology, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | MSDP | 支持MSDP Base Protocol, 静态MSDP peer, MD5 Certificate, Policy For MSDP, MSDP多实例, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
 |  | AnyCast RP | 支持AnyCast RP With MSDP, AnyCast RP With PIM Register
 |  | Multicast Common Feature | 支持Multicast Source Policy, Multicast Boundary, RPF 路由选择, 负载分担(部分支持), Local MT, multi－topology, RPF FRR, LS/VS, 可维护性(部分支持), 可靠性(部分支持)
MPLS业务 | MPLS P2P TE | P2P TE Basis | 支持标签的分发和管理, 隧道维持模式, P2P TE RESPRERESV, Tunnel和接口CAC校验, Session Name, LSP删除, 不使能CSPF或Tunnel Disable CSPF, MPLS LSR ID修改
 |  | P2P TE Path Constraint | 支持显式路径, 优先级抢占, 亲和属性, hop-limit, 仲裁, 带宽约束, 软抢占, 度量约束
 |  | P2P TE Inter Area | -
 |  | P2P TE LSP Optimization and Pinning | 支持重路由, 重优化, 自动带宽调整
 |  | P2P TE Hot-Standby | -
 |  | P2P TE Ordinary | -
 |  | P2P TE Best Effort | -
 |  | P2P TE Tunnel Protection Group | -
 |  | P2P TE Automatic Protection Switching | -
 |  | P2P TE FRR | 支持Manual-Frr, Auto-Frr
 |  | P2P Detour FRR | -
 |  | P2P TE LSP BFD | 支持静态BFD, 动态BFD
 |  | P2P TE Tunnel BFD | -
 |  | P2P TE Attribute Template | -
 |  | P2P TE Graceful Shutdown-Upgrade | 支持Interface Graceful Shutdown, Node Graceful Shutdown
 |  | P2P TE Auto Tunnel | 支持Auto Tunnel-Template, L3VPN trigger Auto Tunnel, L2VPN trigger Auto Tunnel, P2P TE Auto Mesh, P2P TE Auto Direct-hop Tunnel, P2P TE IP-Prefix Auto Tunnel
 |  | P2P TE IGP-TE | 支持洪泛, Shortcut, FA
 |  | P2P TE PCE | 支持托管
 |  | VPN Over TE | -
 | MPLS P2MP TE | P2MP TE Basis | 支持标签的分发和管理, 隧道维持模式, TE转发特性
 |  | P2MP TE Path Constraint | 支持显式路径, 优先级抢占, 亲和属性, hop-limit, 仲裁, 带宽约束, 度量约束, SRLG
 |  | P2MP TE BUD Node | -
 |  | P2MP TE LSP Optimization and Pinning | 支持重路由, 重优化
 |  | P2MP TE Hot-Standby | -
 |  | P2MP TE Ordinary | -
 |  | P2MP TE Tunnel Protection Group | -
 |  | P2MP TE FRR | -
 |  | P2MP TE LSP BFD | -
 |  | P2MP TE Attribute Template | -
 |  | P2MP TE NSF | -
 |  | P2MP TE NSR | -
 |  | P2MP TE ISSU | -
 | MPLS-TP | Bidirectional LSP | 支持静态双向关联LSP, 静态双向共路LSP, 动态双向关联LSP
 |  | Shared Protection Ring | -
 |  | Linear Protection | 支持1:1双端倒换
 | GMPLS UNI | UNI-C Basis | 支持UNI-C隧道建立/更新, 控制和转发分离, 隧道删除
 |  | N端保护与恢复 | 支持1+1保护, 1:1保护, Reroute
 |  | UNI-C Path Constraint | -
 |  | UNI-C Access Interface | 支持VLAN UNI, Ethernet Port UNI, Pos Port UNI
 |  | UNI-C NSR | -
 |  | UNI-C ISSU | -
MPLS交互 | STATIC LSP | Static LSP | -
 |  | Static CR-LSP | -
 | P2P LDP | P2P LDP Basis | 支持LDP session建立, LDP LSP建立与维持, MPLS MTU
 |  | P2P LDP LSP Policy | 支持Lsp-trigger策略, Propagate策略, Outbound策略, Inbound策略, Remote peer pwe3策略, LDP给BGP分标签策略, 代理Egress策略
 |  | P2P LDP DOD | 支持LDP DOD session建立, LDP DOD下LSP建立与维持
 |  | P2P LDP FRR | 支持动态LDP FRR, 动态LDP FRR
 |  | P2P LDP over TE | -
 |  | P2P LDP BFD for LSP | -
 |  | P2P LDP Security | -
 |  | P2P LDP VRF-Instance | -
 |  | P2P LDP InterArea | -
 |  | P2P LDP-IGP | -
 |  | P2P LDP NSR | -
 |  | P2P LDP Distribution | -
 |  | P2P LDP Over GRE | -
 |  | P2P LDP Auto-Config | -
 |  | P2P LDP Supports L2VPN | -
 |  | P2P LDP Supports L3VPN | -
 |  | P2P LDP Routing Loop Detection | -
 |  | LDP LSP转发 | -
 |  | P2P LDP LRVR | -
 |  | P2P LDP MT | -
 |  | P2P LDP 对账 | -
 | P2MP LDP | P2MP LDP Basis | 支持P2MP LDP session 建立, P2MP LDP LSP 建立和维护, MPLS MTU
 |  | P2MP LDP MBB | -
 |  | P2MP LDP MD5 Authentication | -
 |  | P2MP LDP Keychain Authentication | -
 |  | P2MP LDP GTSM | -
 |  | P2MP LDP NSR | -
 |  | P2MP LDP支持L2VPN | -
 |  | P2MP LDP支持MVPN | -
 |  | P2MP LDP Distribution | -
 |  | P2MP LDP Routing Loop Detection | -
 | P2P RSVP | P2P RSVP Basis | 支持CR-LSP建立/刷新, CR-LSP删除, 预留风格, 记录路由和标签, P2P RSVP MTU
 |  | P2P RSVP Authentication | 支持P2P RSVP MD5 Authentication, P2P RSVP keychain Authentication
 |  | P2P RSVP Srefresh and Reliability | -
 |  | P2P RSVP BFD | -
 |  | P2P RSVP Hello Detection | -
 |  | P2P RSVP NSR | -
 |  | P2P RSVP ISSU | -
 |  | P2P RSVP Distribution | -
 |  | P2P RSVP 对账 | -
 | P2MP RSVP | P2MP RSVP Basis | 支持CR-LSP建立/刷新, CR-LSP删除, 预留风格, 记录路由和标签, P2MP RSVP MTU
 |  | P2MP RSVP MD5 Authentication | -
 |  | P2MP RSVP keychain Authentication | -
 |  | P2MP RSVP Srefresh and Reliability | -
 |  | P2MP RSVP BFD | -
 |  | P2MP RSVP Hello Detection | -
 |  | P2MP RSVP NSR | -
 |  | P2MP RSVP ISSU | -
 |  | P2MP RSVP Distribution | -
 | GMPLS RSVP | GMPLS RSVP Basis | 支持动态双向CR-LSP建立, 双向CR-LSP删除
 |  | GMPLS RSVP MD5 Authentication | -
 |  | GMPLS RSVP keychain Authentication | -
 |  | GMPLS RSVP UNI-access Authentication | -
 |  | GMPLS RSVP Notify | -
 |  | GMPLS RSVP Hello Detection | -
 |  | GMPLS RSVP NSF | -
 |  | GMPLS RSVP NSR | -
 |  | GMPLS RSVP ISSU | -
 |  | GMPLS RSVP Distribution | -
 | CSPF | - | -
VPN业务 | L3VPN | L3VPN V4 | 支持L3VPNv4 Basis, L3VPNv4 Staic-L3vpn, L3VPNv4 Inter-AS(部分支持), L3VPNv4 Convergence(部分支持), L3VPNv4 Reliability(部分支持), L3VPNv4 Extension(部分支持), Seamless MPLS
 |  | L3VPN V6 | 支持L3VPNv6 Basis, L3VPNv6 Inter-AS(部分支持), L3VPNv6 Convergence(部分支持), L3VPNv6 Reliability(部分支持), L3VPNv6 Extension(部分支持)
 | MCAST | MVPN | 支持Rosen MVPN(部分支持), NG MVPN(部分支持), IPV6 NG MVPN(部分支持), 可维护性(部分支持), 可靠性(部分支持)
 | VPWS | VPWS Basis | 支持AC Type, 隧道策略
 |  | VPWS Martini | 支持Martini Basis(部分支持), SSPW(部分支持), MSPW
 |  | VPWS Kompella | 支持Kompella Basis, Local Kompella, Remote Kompella
 |  | 公共机制 | 支持LR/VR, 可维护性, 可靠性(部分支持)
 | VPLS | VPLS Basis | 支持AC Type, 隧道策略, AC隔离/水平分割, 忽略AC状态, VPLS mac
 |  | VPLS Extension | 支持OAM for PW, Mac-flapping, 专网环路检测, Auto Session, OAM联动mac-withdraw
 |  | VPLS Martini | 支持Martini Basis(部分支持), HVPLS, VPLS Protection(部分支持)
 |  | VPLS Kompella | 支持Kompella Basis
 |  | VPLS BGPAD | 支持BGPAD Basis, 跨域, VPLS over P2MP
 |  | VPLS Static | 支持Static VPLS
 |  | 公共机制 | 支持LR/VR, 可维护性, 可靠性(部分支持)
 | IPSec | IKEv1 | 支持IPSEC ACL协商, IKEV1认证方法, IKEV1协商方式, IKEV1认证算法, IKEV1加密算法, IKEV1密钥交换算法, IKEV1 SA生存周期, IKEV1 PFS, IKEV1 DPD, IKEv1对等体ID类型
 |  | IKEv2 | 支持IPSEC ACL协商, IKEV2认证方法, IKEV2认证算法, IKEV2加密算法, IKEV2完整性算法, IKEV2密钥交换算法, IKEV2重新认证时间, IKEV2 SA生存周期, IKEV2 PFS, IKEV2 DPD, IKEv2对等体ID类型
 |  | IPSEC基本功能 | 支持IPSEC安全策略(部分支持), IPSEC隧道接口, IPSEC license控制和配置, IPSEC加密IPV4报文
 |  | IPSec 手工SA | 支持手工IPSEC保护平台协议报文
 |  | 可靠性 | 支持HA, ISSU, 双机热备
 |  | 可维护性 | 支持PAF/License, CLI, 日志, 告警, 诊断
 |  | LR/VR | -
 | PKI | 证书秘钥对算法 | 支持RSA密钥对, sm2密钥对
 |  | 证书申请方式 | 支持手动带外申请, HTTP协议获取证书, LDAP协议手工获取证书, CMPv2协议获取证书
 |  | 证书认证 | 支持证书签名验证算法, 交叉认证, 多级CA
 |  | CRL获取/更新方式 | 支持HTTP协议获取CRL, LDAP协议获取CRL, CRL自动更新方式
 |  | 证书白名单 | -
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持CLI, 日志, 告警, 诊断
 |  | LR/VR | -
 | VxLAN | 可维护性 | 支持CLI, 日志, 诊断
系统监控 | NQA | NqaL2vpn | -
 |  | NqaIp | -
 |  | NqaServer | -
 |  | NqaMpls | -
 | 网络诊断 | DgntlL2vpn | -
 |  | DgntlIp | -
 |  | DgntlCommon | -
 |  | DgntlMpls | -
 | BFD | BFD Basis | 支持BFD参数, BFD会话共享, BFD联动, BFD全局shutdown, 软件BFD, BFD AGENT, BFD Dampening, BFD源IP防攻击, BFD Authentication
 |  | BFD for IP | 支持BFD for IPv4, BFD for IPV6
 |  | BFD for LSP | 支持BFD for TE, BFD for P2MP TE, BFD for LDP, BFD for PW, BFD for BGP LSP
 |  | BFD for LogicItf | 支持BFD for Trunk, BFD for VLANIF, BFD for SubIf, BFD for QinQ, BFD for DOT1Q, BFD for METH, BFD for LAG, BFD for PerLink, BFD for LinkBundle, BFD for Gmpls UNI, BFD for Pos-trunk
 | MPLSOAM | MPLS OAM Basis | -
 |  | MPLS OAM for LSP | 支持静态双向关联LSP, 动态双向关联LSP, 静态双向共路LSP, 静态单向TE, 动态单向TE
 |  | MPLS OAM FOR PW | 支持静态单段PW, 静态多段PW, 动态单段PW, 动态多段PW, 静态VSI
 |  | MPLS OAM FOR RING | 支持环网
 |  | MPLS OAM Associate | 支持1AG
 | MPLS-TP OAM | Y.1731 MPLS-TP OAM | 支持TP OAM Basis, TP OAM for IP, TP OAM for LSP, TP OAM for Section, TP OAM for PW, TP OAM for Ring
 | 3AH | Neighbor-Discovery | 支持链路检测, Dyingasp, LinkFault, CriticalEvent
 |  | Fault-Check | 支持误帧检测, 误码检测, 误帧秒检测, 误帧周期事件检测, 误帧误码统计
 |  | Remote-Loop | 支持远端环回使能, 远端环回停止, 环回报文丢弃, 自环检测
 |  | 联动 | 支持3ah联动接口, 3ah扩展主备, 3ah与vrrp联动, 3ah与multihoming联动, 3ah与arp联动, 3ah与mac联动, 3ah与1ag联动
 |  | 11 可靠性 | 支持HA, ISSU
 |  | 12 可维护性 | 支持CLI, log, 诊断
 |  | LS/VS | -
 | 1AG | Connection-Check | 支持基于业务的CC, PortCC, 参数可配置
 |  | LB | -
 |  | LT | -
 |  | Fault-Check | 支持告警类型, 故障通知, 故障恢复, 告警防抖
 |  | APP | 支持vlan内应用, VPLS内应用, VLL内应用, PBT内应用, 组播vlan内应用, PW P2MP应用
 |  | 联动 | 支持检测到故障后清除ARP表项, 本端检测到故障后清除MAC表项, 和bfd联动, 和802.1ag联动, 和802.3ah联动, 和mpls oam联动, 触发所在接口down, 触发其他接口down, 和环网协议联动
 |  | 11 可靠性 | 支持HA, ISSU
 |  | 12 可维护性 | 支持PAF, CLI, log, 诊断
 |  | LS/VS | -
 | Y.1731 | AIS | 支持AIS通告, AIS 终结, Interval功能, 告警抑止功能, vlan封装, AIS触发条件
 |  | Single-Loss | 支持Vlan场景, VPLS场景, VLL场景
 |  | Dual-Loss
 |  | Oneway-Delay
 |  | twoway-Delay
 |  | 带宽通告 | -
 |  | LCK | -
 |  | TEST | -
 |  | 单端合成丢包统计功能 | 支持Vlan场景, VPLS场景, VLL场景, Nobind场景
 |  | 可靠性 | 支持HA, ISSU
 |  | 可维护性 | 支持PAF, CLI, log, 诊断
 | IPFPM | 接口遍历 | -
 |  | 流元组 | -
 |  | 丢包 | -
 |  | 时延 | -
 |  | 逐点丢包时延场景 | -
 |  | PM交互 | -
 |  | 多入口时延 | -
父主题： 设备特性列表


CE交换机

阅读本章有助于您了解CE6800和CE12800设备支持的特性。

模拟CE6800防火墙支持的特性如表1所示。

模拟CE12800防火墙支持的特性如表2所示。

表1 CE6800功能特性列表
零级特性 | 一级特性 | 二级特性 | CE6800
安全 | AAA | 基础配置 | Y
 | ARP安全 | DHCP Snooping | Y
 |  | ARP | Y
 | DHCP Snooping | DHCPv6 | Y
 |  | DHCP | Y
 |  | ARP | Y
 | Keychain | RIP | Y
 |  | OSPF | Y
 |  | IS-IS | Y
 |  | BGP | Y
 | MFF | VLAN | Y
 |  | ARP | Y
 |  | IPSG | Y
 | NAC | AAA | Y
 |  | MAC表 | Y
 | ND Snooping | IPv6基础 | Y
 | SSL | HTTPS | Y
 |  | PKI | Y
 | 防火墙 | BGP/MPLS IP VPN | Y
 | 流量抑制 | 接口基础 | Y
IP业务 | IP Session | DHCP Snooping，BGP/MPLS IP VPN，DHCP，AAA,逻辑接口 | Y
 | IPv4基础 | ipv4基本转发 | Y
 | ARP | ARP安全，以太网接口，MAC表，以太网链路聚合，EVN，DHCP Snooping | Y
 | IPv6基础 | 无 | Y
 | DNS | SSL、基础配置 | Y
 | MDNS | DNS | Y
 | DNSv6 | IPv6 | Y
 | DHCP | DHCP Snooping、基础配置、VRRP、GRE | Y
 | DHCPv6 | IPv6、DHCP Snooping | Y
设备管理 | 信息中心配置 | SNMP | Y
虚拟化配置 | istack | 堆叠硬件要求 | Y
路由 | IP路由基础 | Eth-Trunk | Y
 |  | ARP | Y
 | 静态路由 | BFD | Y
 |  | NQA | Y
 |  | ARP | Y
 |  | L3VPN | Y
 | RIP | ARP | Y
 |  | BFD | Y
 |  | L3VPN | Y
 |  | keychain | Y
 | RIPng | L3VPN | Y
 | OSPF | BFD | Y
 |  | L3VPN | Y
 |  | BGP | Y
 |  | keychain | Y
 | OSPFv3 | L3VPN | Y
 | ISISV4 | ARP | Y
 |  | BFD | Y
 |  | L3VPN | Y
 |  | BGP | Y
 |  | keychain | Y
 | ISISV6 | L3VPN | Y
 | BGP（含MP-BGP） | BFD | Y
 |  | L3VPN | Y
 |  | keychain | Y
 |  | IPv6过渡 | Y
 | TRILL | Eth-Trunk | Y
 |  | E-TRUNK | Y
 |  | MAC | Y
 |  | STP/RSTP/MSTP | Y
 | 设备升级 | 升级指导书 | Y
 | 首次登录 | 硬件 | Y
 | 用户登录 | 硬件 | Y
 |  | VPN | Y
 | 文件管理 | SSL、VPN | Y
接口管理 | 接口基础 | 硬件 | Y
 |  | 以太网交换配置 | Y
 |  | 用户管理配置 | Y
 | 以太网接口 | 硬件 | Y
 |  | 以太网交换配置 | Y
 |  | 用户管理配置 | Y
 | 逻辑接口 | 硬件 | Y
 |  | 以太网交换配置 | Y
 |  | 用户管理配置 | Y
以太网 | STP/RSTP |  | Y
 | MSTP | VRRP | Y
 | 二层协议透明传输 | 无 | Y
 | 链路聚合 | 无 | Y
 | RRPP | 无 | Y
 | ERPS | 以太网OAM | Y
 | VLAN | 子接口 | Y
 |  | OSPF | Y
可靠性 | BFD | 路由 | Y
 |  | VPN | Y
 | DLDP | 无 | Y
 | VRRP | MSTP | Y
 |  | BFD | Y
 |  | NQA | Y
 |  | 路由 | Y
 | Smart Link | 无 | Y
 | CFM | 无 | Y
 | EFM | 无 | Y
 | Y.1731 | 无 | Y
 | 虚拟感知 | 安全 | Y
 |  | 网络管理 | Y
 | NSR | 无 | Y
网络管理 | Ping和Tracert | 无 | Y
 | LLDP | 无 | Y
 | NQA | DNS、FTP、HTTP、ICMP、SNMP、TCP、Trace、UDP、MAC、组播、MPLS、PWE3 | Y
 | RMON | 无 | Y
 | SNMP | 无 | Y
 | netconf | 无 | Y
 | 报文捕获 | 无 | Y
表2 CE12800功能特性列表
零级特性 | 一级特性 | 二级特性 | CE12800
安全 | AAA | 基础配置 | Y
 | ARP安全 | MFF | Y
 |  | DHCP Snooping | Y
 |  | ARP | Y
 | DHCP Snooping | DHCPv6 | Y
 |  | DHCP | Y
 |  | ARP | Y
 | Keychain | RIP | Y
 |  | OSPF | Y
 |  | IS-IS | Y
 |  | MPLS | Y
 |  | BGP | Y
 | MFF | VLAN | Y
 |  | ARP | Y
 |  | IPSG | Y
 | NAC | AAA | Y
 |  | MAC表 | Y
 | ND Snooping | IPv6基础 | Y
 | SSL | HTTPS | Y
 |  | PKI | Y
 | 防火墙 | BGP/MPLS IP VPN | Y
 | 流量抑制 | 接口基础 | Y
MPLS&VPN | BGP/MPLS IP VPN | IP路由 | Y
 | BGP/MPLS IPv6 VPN | IP路由 | Y
 | MPLS LDP | BFD | Y
 |  | IP路由 | Y
 | MPLS TE | BFD | Y
 |  | IP路由 | Y
 |  | L3VPN | Y
 |  | NQA | Y
 | VLL | MPLS LDP | Y
 |  | MPLS TE | Y
 | VPLS | VLL | Y
 |  | MPLS LDP | Y
 |  | BGP | Y
 | EVPN | IP路由 | Y
 | VXLAN |  | Y
IP业务 | IP Session | DHCP Snooping，BGP/MPLS IP VPN，DHCP，AAA,逻辑接口 | Y
 | IPv4基础 | ipv4基本转发 | Y
 | ARP | ARP安全，以太网接口，MAC表，以太网链路聚合，EVN，DHCP Snooping | Y
 | IPv6基础 | 无 | Y
 | DNS | SSL、基础配置 | Y
 | MDNS | DNS | Y
 | DNSv6 | IPv6 | Y
 | DHCP | DHCP Snooping、基础配置、VRRP、GRE | Y
 | DHCPv6 | IPv6、DHCP Snooping | Y
设备管理 | 信息中心配置 | SNMP | Y
虚拟化配置 | VS | NA | Y
路由 | IP路由基础 | Eth-Trunk | Y
 |  | ARP | Y
 | 静态路由 | BFD | Y
 |  | NQA | Y
 |  | ARP | Y
 |  | L3VPN | Y
 |  | MPLS | Y
 | RIP | ARP | Y
 |  | BFD | Y
 |  | L3VPN | Y
 |  | MPLS | Y
 |  | keychain | Y
 |  | L3VPN | Y
 |  | MPLS | Y
 | OSPF | BFD | Y
 |  | L3VPN | Y
 |  | MPLS | Y
 |  | BGP | Y
 |  | keychain | Y
 | OSPFv3 | L3VPN | Y
 |  | MPLS | Y
 | ISISV4 | ARP | Y
 |  | BFD | Y
 |  | L3VPN | Y
 |  | MPLS | Y
 |  | BGP | Y
 |  | keychain | Y
 | ISISV6 | L3VPN | Y
 |  | MPLS | Y
 | BGP（含MP-BGP） | BFD | Y
 |  | L3VPN | Y
 |  | MPLS | Y
 |  | keychain | Y
 |  | IPv6过渡 | Y
 | 路由策略 | L3VPN | Y
 |  | MPLS | Y
 | TRILL | Eth-Trunk | Y
 |  | E-TRUNK | Y
 |  | MAC | Y
 |  | STP/RSTP/MSTP | Y
 | 设备升级 | 升级指导书 | Y
 | 首次登录 | 硬件 | Y
 | 用户登录 | 硬件 | Y
 |  | VPN | Y
 | 文件管理 | SSL、VPN | Y
接口管理 | 接口基础 | 硬件 | Y
 |  | 以太网交换配置 | Y
 |  | 用户管理配置 | Y
 | 以太网接口 | 硬件 | Y
 |  | 以太网交换配置 | Y
 |  | 用户管理配置 | Y
 | 逻辑接口 | 硬件 | Y
 |  | 以太网交换配置 | Y
 |  | 用户管理配置 | Y
以太网 | STP/RSTP |  | Y
 | MSTP | VRRP | Y
 | 二层协议透明传输 | 无 | Y
 | 链路聚合 | 无 | Y
 | RRPP | 无 | Y
 | ERPS | 以太网OAM | Y
 | VLAN | 子接口 | Y
 |  | OSPF | Y
 | MAC表 | VPLS | Y
可靠性 | BFD | 路由 | Y
 |  | MPLS | Y
 |  | VPN | Y
 | DLDP | 无 | Y
 | VRRP | MSTP | Y
 |  | BFD | Y
 |  | NQA | Y
 |  | 路由 | Y
 | Smart Link | 无 | Y
 | CFM | 无 | Y
 | EFM | 无 | Y
 | Y.1731 | 无 | Y
 | 虚拟感知 | 安全 | Y
 |  | 网络管理 | Y
 | NSR | 无 | Y
网络管理 | Ping和Tracert | 无 | Y
 | LLDP | 无 | Y
 | NQA | DNS、FTP、HTTP、ICMP、SNMP、TCP、Trace、UDP、MAC、组播、MPLS、PWE3 | Y
 | RMON | 无 | Y
 | SNMP | 无 | Y
 | netconf | 无 | Y
 | 报文捕获 | 无 | Y
父主题： 设备特性列表


主界面和菜单

  • 引导界面概述
  • 主界面概述
  • 主菜单
  • 工具栏
  • 网络设备区
  • 设备接口区


引导界面概述

打开eNSP工具，将弹出引导界面，指引用户学习并掌握eNSP工具的操作方法。

界面中各区域简要介绍如下表所示。

序号 | 区域名 | 简要描述
1 | 快捷按钮 | 提供“新建”和“打开”拓扑的操作入口。
2 | 样例 | 提供常用的拓扑案例。
3 | 最近打开 | 显示最近已浏览的拓扑文件名称。
4 | 学习 | 提供学习eNSP操作方法的入口。
父主题： 主界面和菜单


主界面概述

阅读本章有助于您熟悉软件主界面。

界面中各区域简要介绍如下表所示。

序号 | 区域名 | 简要描述
1 | 主菜单 | 提供“文件”、“编辑”、“视图”、“工具”、“考试”、“帮助”菜单。
2 | 工具栏 | 提供常用的工具，如新建拓扑、打印等。
3 | 网络设备区 | 提供设备和网线，供选择到工作区。
4 | 工作区 | 在此区域创建网络拓扑。
5 | 设备接口区 | 显示拓扑中的设备和设备已连接的接口。
父主题： 主界面和菜单


主菜单

菜单项说明

主菜单中各菜单项简要说明如下：

菜单项 | 子菜单项 | 快捷键 | 简要说明
文件 | 新建拓扑 | Ctrl+N | 新建拓扑。
 | 新建试卷工程 |  | 新建试卷工程。
 | 打开拓扑 | Ctrl+O | 打开拓扑。
 | 打开示例 | Ctrl+Alt+O | 打开拓扑示例。
 | 保存拓扑 | Ctrl+S | 保存拓扑。
 | 另存为 | Ctrl+Alt+S | 另存为指定文件名和文件类型。
 | 向导 | Ctrl+G | 打开引导界面。
 | 打印 | Ctrl+P | 打印拓扑。
 | 最近打开 | - | 显示最近打开的拓扑文件。
 | 退出 | - | 退出程序。
编辑 | 撤销 | Ctrl+Z | 撤销上次操作。
 | 恢复 | Ctrl+Y | 恢复上次操作。
 | 复制 | Ctrl+C | 拷贝。
 | 粘贴 | Ctrl+V | 粘贴。
视图 | 缩放 | - | 对拓扑图进行放大、缩小、大小重置操作。
 | 工具栏 | - | 用于控制是否显示网络设备区(Left Toolbar)和设备接口区(Right Toolbar)。
工具 | 调色板 | Ctrl+Alt+P | 描绘拓扑图中的图形。
 | 启动设备 | Ctrl+Alt+A | 启动拓扑中选中的设备，默认启动所有未启动设备。
 | 停止设备 | Ctrl+Alt+C | 关闭拓扑中选中的设备，默认关闭所有已启动设备。
 | 数据抓包 | Ctrl+Alt+D | 启动报文采集功能，具体参见报文采集描述。
 | 选项 | Ctrl+Alt+E | 选项设置，具体参照软件参数设置。
 | 合并/展开 CLI | - | 合并/取消合并多个设备的命令行界面到一个窗口。
 | 注册设备 | - | 注册AR、AC、AP等设备。
 | 添加/删除设备 | - | 添加/删除拓展设备
考试 | 阅卷 |  | 评阅试卷。
帮助 | 目录 | F1 | 查看帮助文档。
 | 检查更新 | - | 检测eNSP工具的最新版本信息。
 | 关于 eNSP… | - | 查看软件版本和版权信息。

重点项介绍

  • 报文采集

    在主界面中选择“菜单 > 工具 > 数据抓包”，弹出报文采集对话框。选中设备，再指定接口，单击“开始抓包”，进行报文采集；单击“停止抓包”，停止报文采集。

    说明：
    • 接口处于物理UP状态时，才可以进行报文采集。
    • 接口报文采集设置成功后，右侧的设备接口区中，对应的设备接口指示灯为蓝色。

  • 软件参数设置

    在主界面中选择“菜单 > 工具 > 选项”，在弹出界面中设置软件的参数。

    • 在“界面设置”页面可以设置拓扑中的元素显示效果，比如是否显示设备标签和型号、是否显示背景图。在“工作区域大小”中可设置工作区的宽度和长度。
    • 在“CLI 设置”页面设置命令行中信息保存方式。当选中“记录日志”时，设置命令行的显示行数和保存位置。当命令行界面内容行数超过“显示行数”中的设置值时，系统将自动保存超过行数的内容到“保存路径”中指定的位置。
    • 在“字体设置”页面可以设置命令行界面和拓扑描述框的字体、字体颜色、背景色等参数。
    • 在“服务器设置”页面可以设置服务器端参数，详细信息请参考分布式部署。
    • 在“工具设置”页面可以指定“引用工具”的具体路径。

父主题： 主界面和菜单


工具栏

工具栏提供如下工具：

工具 | 简要说明 | 工具 | 简要说明
 | 新建拓扑。 |  | 新建试卷工程。
 | 打开拓扑。 |  | 保存拓扑。
 | 另存为指定文件名和文件类型。 |  | 打印拓扑。
 | 撤销上次操作。 |  | 恢复上次操作。
 | 恢复鼠标。 |  | 选定工作区，便于移动。
 | 删除对象。 |  | 删除所有连线。
 | 添加描述框。 |  | 添加图形。
 | 放大。 |  | 缩小。
 | 恢复原大小。 |  | 启动设备。
 | 停止设备。 |  | 采集数据报文。
 | 显示所有接口。 |  | 显示网格。
 | 打开拓扑中设备的命令行界面。 |  | eNSP论坛。
 | 华为官网。 |  | 选项设置。
 | 帮助文档。 |  |
父主题： 主界面和菜单


网络设备区

设备类别区

提供eNSP支持的设备类别和连线。

根据在此处的选择，“设备型号区”的内容将会变化。您可以将此区域的设备直接拖至工作区，系统默认将“设备型号区”中该类别的第一种型号的设备添加至工作区中。

表1 设备类别表
图标 | 说明
 | 企业路由器
 | 企业交换机
 | WLAN设备
 | 防火墙
 | 终端设备
 | 其他设备
 | 自定义设备
 | 连接线

设备型号区

提供设备和网线具体型号，供选择到工作区。

表2 设备型号表
图标 | 说明
 | AR系列的接入路由器，包含CON/AUX接口、以太网接口、WAN侧上行接口、USB接口，Console口。
 | S5700–28C-HI型号的企业级交换机，包含24个10/100/1000BASE-T以太网接口、1个Console口、1个管理网口、1个USB口。
 | S3700–26C-HI型号的企业级交换机，包含22个10/100BASE-T以太网接口、2个千兆Combo口(10/100/1000BASE-T+100/1000BASE-X)、1个Console口、1个管理网口、1个USB口。
 | CE6800型号的数据中心交换机。
 | AC6005型号的AC设备，包含6个10/100/1000BASE-T以太网接口、2个Combo接口、1个Console接口和1个USB接口。
 | AC6605型号的AC设备，包含24个10/100/1000BASE-T以太网接口、4个Combo接口、1个Console接口、1个RS-232维护串口和1个Mini USB维护接口（与RS-232口互斥）。
 | AP设备包含AP2010、AP2030、AP2050、AP3030、AP4030、AP4050、AP5030、AP6050、AP7030、AP7050、AP8030、AP8130和AP9131。
 | AD9430型号的AD（中心AP）设备。
 | R250D型号的SAP（RRU）设备。
 | USG防火墙设备包括USG5500和USG6000v。
 | PC机，包含1个以太网接口，可模拟发送和接收数据报文。
 | 组播源，包含1个以太网接口，可向PC发送组播数据报文。
 | 客户端，包含1个以太网接口，可模拟FTP客户端和HTTP客户端。
 | 服务器，包含1个以太网接口，可模拟DNS服务器，FTP服务器和HTTP服务器。
 | 带无线网卡的笔记本模拟器，包括一个wifi口，可模拟发送和接收无线数据报文。
 | 手机模拟器，一个wifi口，可模拟收发无线报文。
 | 云，可动态配置设备接口，管理端口映射规则，将端口与真实网卡绑定。
 | 帧中继交换机，包含16个串口。可模拟DLCI标签交换过程。
 | 集线器，包含16个以太口。
 | 以太网线，连接设备的以太网接口。
 | 串口线，连接设备的串口。
 | POS口连接线，连接路由器的POS口。
 | E1口连接线，连接路由器的E1口。
 | ATM口连接线，连接路由器的4G.SHDSL口。
 | Console口连接线，PC与设备之间的串口连线。
父主题： 主界面和菜单


设备接口区

此区域显示拓扑中的设备和设备已连接的接口。双击或者拖动标题栏时可以将其脱离主界面，增大工作区可视面积。再次双击或者拖动标题栏时，可以将其放回至原位置。

指示灯颜色含义

  • 红色：设备未启动或接口处于物理DOWN状态。
  • 绿色：设备已启动或接口处于物理UP状态。
  • 蓝色：接口正在采集报文。

右键功能说明

  • 右键单击设备名，可启动/停止设备。

  • 右键单击处于物理UP状态的接口名，可启动/停止接口报文采集。

父主题： 主界面和菜单


快速入门

阅读本章有助于用户快速入门，掌握eNSP的常用操作。本章以几个小任务引导用户快速熟悉eNSP的基本功能。

  • 新建拓扑
  • 数据实验
  • 报文采集实验
  • 组播实验
  • C/S组网实验
  • WLAN组网实验
  • 考试功能介绍


新建拓扑

拓扑是进行网络实验的基础，本节以一台交换机和两台PC组建小型拓扑为例，介绍如何组建简单拓扑。

操作步骤

  1. 开启eNSP客户端。
  2. 向工作区中添加一台交换机和两台PC。

    1. 在设备类别区选择 [image] 。
    2. 在设备型号区选择具体的型号“S5700”。
    3. 在工作区单击左健即完成，或者直接将设备拖至工作区。

      参考以上步骤添加两台PC至工作区。您还可以添加更多的设备，组建更大型的拓扑。

      说明：
      • 每台设备带有默认描述，通过单击您可以对它进行修改。
      • 通过工具栏的 [image] ，可在拓扑中任意添加描述。
      • 通过工具栏的 [image] ，可向拓扑中添加图形标识。

  3. 向工作区中添加两条网线，使两台PC分别与交换机相连。

    1. 在设备类别区选择 [image] 。
    2. 在设备型号区选择具体的型号“Auto”。
    3. 在工作区依次单击交换机和一台PC。

      类似步骤连接交换机和另一台PC。

      说明：

      当网线仅一端连接了设备后希望取消连接时，在工作区右击或者按“Esc”键即可。

  4. 启动工作区的设备。右键单击设备，选择“启动”。您也可以在工作区中用鼠标选定一个区域，单击工具栏的 [image] ，批量启动该区域的设备。

    说明：

    关注连线指示灯颜色的变化，红色表示设备间未连通，绿色表示设备间已连通。

  5. 双击工作区交换机图标，直接进入命令行界面。

    主要配置都在命令行界面进行，详细命令请参考如何获取设备命令帮助文档。

  6. 单击工具栏的 [image] ，输入名称，保存拓扑。
父主题： 快速入门


数据实验

本节以第1个任务中新建的拓扑为基础，介绍在模拟PC端的常用操作。

操作步骤

  1. 开启eNSP客户端。
  2. 在工具栏中单击 [image] ，加载新建的拓扑。
  3. 在工具栏中单击 [image] ，启动全部的设备。
  4. 配置两台PC的IP地址和子网掩码。

    1. 在工作区双击一台PC图标。
    2. 在“配置”界面，IP地址配置为“192.168.1.2”，子网掩码配置为“255.255.255.0”。
    3. 类似的步骤，配置另一台PC的IP地址和子网掩码分别为“192.168.1.3”和“255.255.255.0”。

  5. 由PC（CLIENT0）向另一台PC（CLIENT1）发送Ping报文。

    1. 在工作区双击PC（CLIENT0）图标。
    2. 单击“命令行”，进入“命令行”页签。
    3. 输入命令ping 192.168.1.3。可看到已成功“Ping”通PC（CLIENT1）。

  6. 保存拓扑，退出程序。
父主题： 快速入门


报文采集实验

分析数据报文有助于您理解网络协议的原理。本节以第2个任务配置的拓扑为基础，介绍获取数据报文的方法。

前提条件

客户端已安装Wireshark。

背景信息

eNSP利用第三方网络数据报文分析工具Wireshark，实现数据报文的获取与分析。

eNSP提供以下多种便捷操作入口启动报文采集(仅支持交换机和路由器)：

  • 设备上指定端口启动
  • 工具栏按钮启动
  • 接口视图链路启动

操作步骤

  1. 开启eNSP客户端。
  2. 在工具栏中单击 [image] ，加载新建的拓扑。
  3. 在工具栏中单击 [image] ，启动全部的设备。
  4. 以在设备上指定端口启动报文采集为例，右键单击交换机图标，选择“数据抓包”，再选择端口，启动报文采集程序Wireshark。

    在端口列表中该端口的指示灯变为蓝色。

  5. 从采集报文的PC向另一台PC发送Ping报文。在Wireshark上查看获取的Ping报文。

    您也可发送ARP类型报文，获取查看。

  6. 停止报文采集。右键单击正在采集报文的交换机图标，选择“数据抓包”，取消选择端口，则停止报文采集。
  7. 保存拓扑，退出程序。
父主题： 快速入门


组播实验

本节以组播示例拓扑为基础，介绍组播在eNSP平台上播放视频的实际应用。

前提条件

已安装视频播放器“VLC media player”。

背景信息

安装目录中提供了多个示例拓扑，供用户参考。

组播源实现简单的组播数据流发送，便于直观地测试组播特性。

操作步骤

  1. 开启eNSP客户端。
  2. 在工具栏中单击 [image] ，加载安装目录“\example\multicast”中的文件“multicast.topo”。
  3. 在工具栏中单击 [image] ，启动全部的设备。
  4. 双击组播源图标，在弹出界面中选择“组播源”页面，单击“浏览”选择视频源。设置视频源后，单击“运行”开始播放视频。

    说明：
    • 视频源支持mp4、wmv、mpeg、flv格式。
    • 示例拓扑中组播源的网络参数已经配置。在“基础配置”页面配置组播源的IP地址和MAC地址等。在“组播源”页面的“配置”区域配置组播组的IP地址和MAC地址等。

  5. 在拓扑中双击任意模拟PC图标，在弹出界面中选择“组播”页面，单击“加入”加入组播组，单击“启动 VLC”播放组播源的视频。对另一台模拟PC做同样操作，可以观察到2台模拟PC同步播放视频。此时组播源的视频数据流已经组播到2台模拟PC上。若单击“离开”则离开组播组，停止播放视频。

    说明：

    示例拓扑中各模拟PC的网络参数已经配置。在“组播”页面的“数据包配置”区域配置组播参数，其中源IP地址和源MAC地址是本设备的，目的MAC地址和IP地址是组播源的组播MAC地址和组播IP地址。

  6. 退出程序。

父主题： 快速入门


C/S组网实验

通过C/S（客户端/服务器）组网实验，可以了解网络上Ftp服务和Http服务的实现方法。本节以简单的C/S组网实现多种服务为例，介绍C/S网络中客户端和服务器的配置方法。

背景信息

eNSP工具的终端设备中有客户端和服务器两种设备，通过这两种设备可以组建简单的C/S网络，实现Ftp服务和Http服务。

服务 | 实现说明
Ftp服务 | 将客户端配置成Ftp客户端，并将对应的服务器配置成Ftp服务器。 通过在Ftp客户端上登录Ftp服务器来实现文件传输服务。
Http服务 | 将客户端配置成Http客户端，将服务器配置成Http服务器。 通过在Http客户端上输入服务器的IP地址来访问Http服务器。 说明： 如果希望通过域名访问Http服务器，需要配置DNS服务器。

操作步骤

  1. 构建基本拓扑。

    1. 开启eNSP客户端。
    2. 向工作区添加一台客户端和一台服务器。
    3. 向工作区中添加一条网线，使客户端和服务器相连。

  2. 配置服务器信息。

    1. 配置基本信息。

      双击服务器图标，在“基础配置”页面设置服务器的相关参数。

    2. 配置DNS服务器信息。

      在“服务器信息”页面的左侧导航树中选择“DNSServer”，配置DNSServer的相关参数。

    3. 配置FTP服务器信息。

      在“服务器信息”页面的左侧导航树中选择“FtpServer”，配置FtpServer的相关参数。

    4. 配置HTTP服务器信息。

      在“服务器信息”页面的左侧导航树中选择“HttpServer”，配置HttpServer的相关参数。

  3. 配置客户端信息。

    1. 配置基本信息。

      双击客户端图标，在“基础配置”页面设置客户端的相关参数。

    2. 配置FTP客户端信息。

      在“客户端信息”页面的左侧导航树中选择“FtpClient”，设置相关参数。

      说明：
      • 文件传输模式：“PASV”表示被动模式，“PORT”表示主动模式。
      • 类型：“Binary”表示程序类型的文件，“ASCII”表示文本模式的文件，“Auto check”表示自动选择。
      • 目录中只能显示大小为1M以内的文件。

  4. 结果验证。

    1. FTP服务。
      1. 在工具栏中单击 [image] ，启动全部设备。
      2. 双击服务器图标，在“服务器信息”页面的左侧导航树中选择“FtpServer”，单击“启动”。
      3. 双击客户端图标，在“客户端信息”页面的左侧导航树中选择“FtpClient”，单击“登录”。

      4. 在“服务器文件列表”中选择download.txt文件，单击左侧的 [image] ，提示文件下载成功，在“本地文件列表”可以看到该文件。
      5. 在“本地文件列表”中选择upload.txt文件，单击右侧的 [image] ，提示文件上传成功，在“服务器文件列表”可以看到该文件。

    2. HTTP服务。
      1. 双击服务器图标，在“服务器信息”页面的左侧导航树中选择“HttpServer”，单击“启动”。
      2. 双击客户端图标，在“客户端信息”页面的左侧导航树中选择“HttpClient”，在地址栏中输入“10.10.10.1/1.html”，单击“获取”。
      3. 弹出文件下载提示框，说明Http服务配置正确。

    3. DNS服务。
      1. 双击服务器图标，在“服务器信息”页面的左侧导航树中选择“DNSServer”，单击“启动”。
      2. 双击客户端图标，在“客户端信息”页面的左侧导航树中选择“HttpClient”，在地址栏中输入“www.huawei.com/1.html”，单击“获取”。
      3. 弹出文件下载提示框，说明DNS服务配置正确。

父主题： 快速入门


WLAN组网实验

本节以WLAN漫游上线拓扑为例，介绍如何在eNSP平台上实现WLAN业务的具体应用。

背景信息

WLAN安全认证配置示例拓扑中的设备上已经配置了实现WLAN业务的相关命令，因此只要直接打开就可以模拟WLAN的安全认证。

如果您想自己搭建组网并实现相关业务，那么需要在AC和AP设备上配置相关的命令，具体的配置命令请参考相应的设备手册。

操作步骤

  1. 开启eNSP客户端。
  2. 在工具栏中单击 [image] ，加载安装目录“\example\Security Authentication”中的文件“Security Authentication.topo”。

  3. 在工具栏中单击 [image] ，启动全部的设备。
  4. 使STA1连上Wi-Fi。

    1. 双击STA1，弹出“STA1”界面。
    2. 在“Vap列表”区域，选择“SSID”为“huawei”的Wi-Fi，单击“连接”。

    3. 从拓扑图上可以看出，STA1成功连接上了Wi-Fi。

父主题： 快速入门


考试功能介绍

  • 新建试卷工程
  • 考试交卷
  • 阅卷
父主题： 快速入门


新建试卷工程

本节以两台交换机组建一小型试卷工程为例，介绍如何新建试卷工程。

操作步骤

  1. 开启eNSP客户端。
  2. 工具栏单击 [image] ，弹出新建窗口，以工程名称123，工程位置桌面为例。

    您也可以在主界面选择“菜单->文件->新建试卷工程”。

  3. 设计考题拓扑。

    1. 点击确定按钮，弹出新建试卷工程界面，默认为设计考题拓扑界面。

    2. 在工作区搭建考题拓扑，以两台交换机组网为例。

    也可以点击提示框后方 [image] 按钮，导入拓扑文件。

    您还可以添加更多的设备，组建更大型的拓扑。

    3. 启动设备后，双击工作区设备图标，进入命令行界面进行配置。

    主要配置都在命令行界面进行，详细命令请参考如何获取设备命令帮助文档。

    说明：

    配置完成后，务必在设备命令行输入save命令来保存配置！

  4. 编写考试说明。点击进入编写考试说明界面，工作区内编写考试说明。

  5. 生成试卷&答案。

    1. 点击进入生成试卷&答案。

    2. 在界面区域1可设置各得分点分数。

    3. 界面区域2是答案设置区域，默认为完全匹配答案，可选择其他匹配规则，也可选择Regular自定义设置正则表达式。

    正则表达式举例：

    • 如sysname.*可以匹配以sysname开头的命令。
    • 如ip route-static (0.0.0.0 0.0.0.0 10.1.1.1)|(10.1.2.1 255.255.255.0 10.1.1.1)可以匹配ip route-static 0.0.0.0 0.0.0.0 10.1.1.1命令以及ip route-static 10.1.2.1 255.255.255.0 10.1.1.1命令。

    4. 在界面区域3可以设置总分以及标识还剩下多少分。

    5. 在界面区域4设置考试计时方式。勾选锁定试卷功能后，考生打开试卷，将禁止添加或删除设备。

    6. 在界面区域5设置答案以及试卷的保存路径，并导出答案和试卷

    说明：
    • 在设计考题拓扑时，如不保存命令，则无法显示设备配置列表。
    • 设备配置列表中，若要设置为得分点，需勾选中再设置其分值，否则不计入总分值。
    • 如果设置的答案（非正则表达式情况下）带有 “(” 、“）”、“{”、“ }”、“[”、“ ]”字符，需要在这些字符前面加上“\”， 否则有可能导致阅卷时无法匹配到正确答案。

  6. 完成。点击完成弹出提示按钮保存当前工程。
父主题： 考试功能介绍


考试交卷

本节介绍学生考试交卷操作。

操作步骤

  1. 开启eNSP客户端。
  2. 在工具栏中单击 [image] ，加载.paper考题拓扑。

    您还可以双击.paper文件或者拖拽.paper到eNSP工作来打开试卷。

  3. 在工具栏中单击 [image] ，启动全部的设备。
  4. 按照考试说明配置设备。

    说明：

    点击主界面右下角的显示考试说明可以重新打开关闭的考试说明。

  5. 点击界面右下角交卷按钮，弹出交卷窗口，以用户ID123，保存路径为桌面为例。

    或者在主界面中选择“菜单->考试->交卷”按钮进行交卷。

  6. 点击生成答案按钮完成交卷工作。

父主题： 考试功能介绍


阅卷

本节介绍考试阅卷操作。

操作步骤

  1. 开启eNSP客户端。
  2. 在主界面中选择“菜单->考试->阅卷”。
  3. 在弹出界面中，选择考题答案保存路径及学生答案保存路径。

    说明：

    将学生答案放在同一文件夹下可以实现批量阅卷。

  4. 点击“阅卷”，弹出“阅卷结束！是否查看阅卷结果？”的提示，点击“是”查看阅卷结果。

  5. 阅卷结果界面，点击“详情”可查看该ID对应的试卷得分点得分情况。
  6. 点击“显示详情”可查看考生的完整配置。
  7. 根据考生配置，可在“考生得分”对应列下方白色方框内修改各得分点得分，修改后点击“保存”按钮，弹出提示，点击“是”。

    说明：
    • 修改得分后请务必点击保存按钮。
    • 阅卷结果只支持IE浏览器打开，打开后，浏览器上方弹出黄色提示，需要点一下“允许阻止的内容”，弹出安全警告提示，请点击“是”。

父主题： 考试功能介绍


灵活部署

eNSP提供灵活的部署方案，满足多种场景的应用需求。

系统组成

eNSP使用C/S架构，Client端和Server端可部署在一台PC上，也可将Server端分布式部署在多台服务器上。

  • Client端：管理用户设计拓扑、配置业务等操作。
  • Server端：负责运行设备仿真程序及保存用户拓扑信息。

单机部署

Client端和Server端部署到一台PC上，组建的拓扑规模受PC配置影响，一般用来组建小型拓扑，便于自学。

图1 单机部署

分布式部署

Client端部署在前台PC端，Server端部署在服务器端。Server端可部署在多台服务器上，系统支持自动分配服务器资源。

图2 分布式部署
  • 分布式部署


分布式部署

在分布式部署方案中，需要配置服务器端和客户端。

配置服务器端

服务器端通过IP和端口号的组合方式提供服务。本文仅介绍配置端口号的方法。

  1. 在主界面中选择“菜单 > 工具 > 选项”。在弹出界面中选择“服务器设置”页签。
  2. 在“本地服务器”区域设置本地服务器的端口号。
    说明：

    为了避免与其他程序使用的端口号冲突，建议使用较大的端口号，如60000–65534之间。

  3. 重新启动程序使设置生效。

配置客户端

  1. 在主界面中选择“菜单 > 工具 > 选项”。在弹出界面中选择“服务器设置”页签。
  2. 在“远程服务器”区域设置服务器的IP地址和端口号后，单击“测试”。

  3. 测试成功后，单击“添加”将服务器加入服务器列表。
  4. 单击“确定”。
父主题： 灵活部署


设备配置

和真实的环境一样，在eNSP平台的设备需要进行合理配置后才能正常工作。

交换机

右键单击拓扑中的设备图标，选择“CLI”，进入设备命令行界面，使用命令行来配置设备。

右键单击拓扑中的设备图标，选择“设置”，进入设备接口配置界面。

  • 在“视图”页面，可以查看设备面板。

  • 在“配置”页面，可以设置设备的串口号。

路由器

右键单击拓扑中的设备图标，选择“CLI”，进入设备命令行界面，使用命令行来配置设备。

右键单击拓扑中的设备图标，选择“设置”，进入设备接口配置界面。

  • 在“视图”页面，可以为设备添加接口卡，增加设备的接口数。

    如果需要为设备增加接口，可以在“eNSP支持的接口卡”区域选择合适的接口卡，直接拖至上方的设备面板上即可。

    如果需要删除某个接口卡，直接将设备面板上的接口板拖回“eNSP支持的接口卡”区域即可。

    说明：

    只有在设备关闭的情况下才能进行增加或删除接口卡的操作。

  • 在“配置”页面，可以设置设备的串口号。

模拟PC

在“配置”页面，配置设备的基础参数，如IP地址、子网掩码和MAC地址等。

当需要从PC端执行命令时，可在“命令行”页面输入相应的命令行。

在“组播”页面，配置组播的相关参数，包括源MAC、源IP、目的MAC和目的IP。

在“UDP发包工具”页面，配置PC发送大量UDP分片的相关参数。

在“串口”页面，可在“命令行”页面输入连接设备相应的命令行。

组播源

在“基础配置”页面，配置设备的基础参数，内容与模拟PC相同。

在“组播源”页面，配置组播的相关参数。在“文件路径”中设置视频源文件。在“配置”区域设置组播源的组播MAC和组播IP。


系统配置要求

单机版

项目 | 最低配置 | 推荐配置 | 扩展配置
CPU | 双核2.0GHz或以上 | 双核2.0GHz或以上 | 双核2.0GHz或以上
内存(GB) | 2 | 4 | 4 + n (n > 0)
空闲磁盘空间(GB) | 2 | 4 | 4
操作系统 | Windows XP Windows Server 2003 Windows 7 Windows 10 | Windows XP Windows Server 2003 Windows 7 Windows 10 | Windows XP Windows Server 2003 Windows 7 Windows 10
VirtualBox | xp/win7 VirtualBox 4.2.3以上 win10 VirtualBox 5.0以上 | xp/win7 VirtualBox 4.2.3以上 win10 VirtualBox 5.0以上 | xp/win7 VirtualBox 4.2.3以上 win10 VirtualBox 5.0以上
最大组网设备数(台) | 10 | 24 | 24 + 10*n

多机版

- | 项目 | 最低配置 | 推荐配置 | 扩展配置
服务器端 | CPU | 双核2.0GHz或以上 | 双核2.0GHz或以上 | 双核2.0GHz或以上
 | 内存(GB) | 2 | 4 | 4 + n (n > 0)
 | 空闲磁盘空间(GB) | 2 | 4 | 4
 | 操作系统 | Windows XP Windows Server 2003 Windows 7 Windows 10 | Windows XP Windows Server 2003 Windows 7 Windows 10 | Windows XP Windows Server 2003 Windows 7 Windows 10
 | VirtualBox | xp/win7 VirtualBox 4.2.3以上 win10 VirtualBox 5.0以上 | xp/win7 VirtualBox 4.2.3以上 win10 VirtualBox 5.0以上 | xp/win7 VirtualBox 4.2.3以上 win10 VirtualBox 5.0以上
 | 最大组网设备数(台) | 10 | 24 | 24 + 10*n
客户端 | CPU | 双核2.0GHz或以上 | 双核2.0GHz或以上 | -
 | 内存(GB) | 1 | 2
 | 空闲磁盘空间(GB) | 0.1 | 0.2
 | 操作系统 | Windows XP Windows Server 2003 Windows 7 Windows 10 | Windows XP Windows Server 2003 Windows 7 Windows 10
说明：

eNSP上每台虚拟设备都要占用一定的资源。每台电脑支持的虚拟设备数，根据配置的不同而有差别。表格中，n是整数，表示增加的内存大小。扩展配置的最大组网设备数可根据内存增加而扩展，最大为50。


FAQ

  • 如何获取设备命令帮助文档
  • 如何获取设备支持文档
  • 如何解决设备启动失败问题
  • 如何设置命令行和拓扑描述框的背景颜色和字体
  • 如何在工作区显示更大区域的拓扑
  • eNSP支持组建多大规模的网络
  • eNSP支持同时运行多少台设备
  • 如何通过SecureCRT登录eNSP模拟设备
  • 如何进行设备配置文件的导入与导出
  • 如何使用云设备
  • 如何让SecureCRT连接到仿真设备后支持Tab键操作
  • 如何解决使用eNSP工具时CPU利用率过高的问题
  • 防火墙USG6000V如何登陆web网管
  • 如何解决云设备绑定网卡无法通信问题
  • 如何解决AR/WLAN设备启动失败问题
  • 如何解决交换机设备启动失败问题
  • 如何解决USG5500启动失败问题
  • 如何解决CE、NE和CX设备启动失败问题
  • 如何解决USG6000V启动失败问题
  • 如何正确使用USG6000V
  • 如何正确使用CE、NE和CX设备
  • 如何注册eNSP设备
  • 如何添加自定义设备
  • AC设备如何登陆web网管
  • 如何手动修改NE、CX和CE设备的内存


如何获取设备命令帮助文档

您可以在华为企业业务网站上浏览和获取相关的文档。

  • AR设备命令帮助文档的网址为：http://support.huawei.com/enterprise/?popuplay=7923146.
  • 交换机设备命令帮助文档的网址为http://support.huawei.com/enterprise/?popuplay=9856733：
  • 防火墙设备命令帮助文档的网址为：http://support.huawei.com/enterprise/?popuplay=9856724
说明：

eNSP提供对设备的模拟功能，与真实设备间存在差异。eNSP并不支持命令帮助文档中介绍的所有特性与命令。

父主题： FAQ


如何获取设备支持文档

您可以通过华为官方网站浏览和获取设备相关的文档。

  1. 进入网站主页http://enterprise.huawei.com/cn/。
  2. 单击“登录”，输入帐号、密码及系统给出的校验码并登录。
    说明：
    • 部分文档无需登录即可查看并下载。
    • 登录帐号、密码仅对部分代理商用户发放，具体请联系华为公司客服热线：400-830-2118。
  3. 登录成功后，在企业用户页面选择“技术支持”。
  4. 按照分类导航查找或者搜索设备相关的文档。
父主题： FAQ


如何解决设备启动失败问题

如何解决AR/WLAN设备启动失败问题。

如何解决交换机设备启动失败问题。

如何解决CE、NE和CX设备启动失败问题。

如何解决USG6000V启动失败问题。

如何解决USG5500启动失败问题 。

父主题： FAQ


如何设置命令行和拓扑描述框的背景颜色和字体

  1. 在主界面中选择“菜单 > 工具 > 选项”，
  2. 在弹出界面中选择“字体设置”。
  3. 单击“字体”后的“选择”设置字体，单击“字体颜色”后的“选择”设置字颜色，单击“背景颜色”后的“选择”设置背景色。“CLI字体”区域对命令行界面设置有效，“默认文字标注颜色”区域对拓扑描述框设置有效。
    说明：

    在拓扑中右键单击描述框，可对单个描述框的背景颜色和字体进行设置。

  4. 单击“确定”，使设置生效。若要恢复默认设置，单击“默认”。

父主题： FAQ


如何在工作区显示更大区域的拓扑

  • 通过清除选择主界面的“菜单 > 视图 > 工具栏”中的选项，可隐藏左右侧区域和上侧工具栏。
  • 在工具栏中单击 [image] 或选择“菜单 > 视图 > 缩放 > 缩小”，适当缩小拓扑图的比例。
父主题： FAQ


eNSP支持组建多大规模的网络

如果只是组网，不启动设备的话，程序占用的内存较小。所以对组网的规模没有上限限制，但建议组网时考虑组网区域的大小，以便所有设备都能在组网区域中显示。

父主题： FAQ


eNSP支持同时运行多少台设备

每台设备启动之后占用300MB左右的内存，如果电脑内存越大，eNSP上能同时运行的设备也就越多。在内存较小的机器上建议不要启动太多设备。请参考系统配置要求。

父主题： FAQ


如何通过SecureCRT登录eNSP模拟设备

通过对第三方终端工具进行简单配置后，即可登录eNSP模拟设备。下面将以SecureCRT工具为例，详细介绍配置方法。

  1. 查询模拟设备的登录端口号。

    在eNSP软件的接口视图中，设备名称后面将显示一个端口号，该端口号即使用第三方工具时需要设置的端口号。

  2. 配置第三方登录软件SecureCRT。
    1. 打开SecureCRT软件，在主菜单中选择“选项 > 全局选项”，打开“全局选项”配置界面。
    2. 在左侧导航树中选择“常规 > 默认会话”，单击“编辑默认设置”，打开“会话选项”界面。

    3. 在左侧导航树中选择“连接”，并设置终端协议为“Telnet”。

    4. 在左侧导航树中选择“连接 > Telnet”，勾选“强制每次一个字符模式（R）”。

    5. 在左侧导航树中选择“终端 > 仿真”，设置仿真终端为“VT100”。

  3. 通过SecureCRT工具，新建会话并登录eNSP模拟设备。
    1. 打开SecureCRT软件，在主菜单中选择“文件 > 连接”，打开“连接”界面。
    2. 在“连接”界面中，单击“新建会话”，打开“新建会话向导”。

    3. 在“新建会话向导”中，设置“SecureCRT协议”为“Telnet”。

    4. 单击“下一步（N）”，输入“主机名”和“端口”。
      说明：

      端口号即为eNSP软件的接口视图中设备名称后面显示的端口号。

    5. 后续操作可直接下一步，直到完成即可。
父主题： FAQ


如何进行设备配置文件的导入与导出

导入设备配置文件

  1. 在交换机或路由器未启动的状态下，右键单击设备，并选择“导入设备配置”。

  2. 选择设备配置文件（.cfg或者.zip格式），并导入到设备中。
  3. 下次启动设备时，将会加载导入的配置文件。

导出设备配置文件

  • 设备启动后，导出设备配置文件
  1. 启动设备，并双击设备图标，弹出“CLI”界面。
  2. 在“CLI”界面中，使用save命令保存配置信息。
  3. 右键单击设备，并选择“导出设备配置”。

  4. 输入设备配置文件的文件名，并将设备配置信息导出为.cfg文件。
  • 加载拓扑后，导出设备配置文件
  1. 加载已保存的拓扑。
  2. 右键单击设备，并选择“导出设备配置”。

  3. 输入设备配置文件的文件名，并将设备配置信息导出为.cfg文件。
  • 设备完成导入配置文件后，导出设备配置文件
  1. 将配置文件导入设备。
  2. 右键单击设备，并选择“导出设备配置”。

  3. 输入设备配置文件的文件名，并将设备配置信息导出为.cfg文件。
父主题： FAQ


如何使用云设备

eNSP工具中的云代表通过各种网络技术连接起来的计算机网络环境，目前可实现的功能包括：仿真设备之间建立映射关系、绑定网卡与仿真设备之间进行通信，以及通过开放UDP端口方式与外部程序进行通信。

下面将详细介绍各种功能的使用方法。

  • 在仿真设备之间建立映射关系。
  1. 开启eNSP客户端。
  2. 向工作区中添加“云”。
  3. 双击“云”图标，打开“云”配置界面。

  4. 创建UDP端口。
    1. 在“端口创建”区域框中，依据连接至云的设备接口类型选择相应的“端口类型”。
    2. “绑定信息”选择“UDP”。
    3. 单击“增加”。
    说明：

    创建UDP端口时，不可勾选“开放UDP端口”。

  5. 根据已创建的端口信息，配置端口映射。
    1. 选择“端口类型”。
    2. 选择“入端口编号”和“出端口编号”。如配置“入端口编号”为“1”、“出端口编号”为“2”，则表示从“1”端口进入云的数据，都从“2”端口送出。
    3. 勾选“双向通道”，即表示同时添加反向映射关系。
    4. 单击“增加”，即在“端口映射表”中显示相应的端口映射关系。
  6. 返回工作区，手动在设备与“云”之间建立链路，此时云端将显示已创建的端口信息。

  7. 完成如下拓扑图后，两台设备之间可以相互Ping通。

  • eNSP绑定本地网卡，与仿真设备进行通信。
  1. 开启eNSP客户端。
  2. 向工作区中添加“云”。
  3. 双击“云”图标，打开“云”配置界面。

  4. 创建端口。
    1. 在“端口创建”区域框中，依据连接至云的设备接口类型选择相应的“端口类型”。
    2. “绑定信息”选择“本地连接...”。
    3. 单击“增加”。
    说明：
    • 使用云进行网卡绑定时，请务必不要绑定公共网络使用的网卡，否则可能会引起（如华为桌面云）动态地址池内网络故障，华为内部用户会涉及安全违规。
    • 由于建立端口映射至少需要两个端口，可参考之前操作新建UDP端口即可。
  5. 根据已创建的端口信息，配置端口映射。
    1. 选择“端口类型”。
    2. 选择“入端口编号”和“出端口编号”。
    3. 勾选“双向通道”，即表示同时添加反向映射关系。
    4. 单击“增加”，即在“端口映射表”中显示相应的端口映射关系。
  6. 完成如下拓扑图，并将直连设备的IP地址设置在同一网段，即可实现本机与仿真设备之间相互通信。

  • 配置开放UDP端口，实现与外部程序通信。
  1. 开启eNSP客户端。
  2. 向工作区中添加“云”。
  3. 双击“云”图标，打开“云”配置界面。

  4. 创建端口。
    1. 在“端口创建”区域框中，依据连接至云的设备接口类型选择相应的“端口类型”。
    2. “绑定信息”选择“UDP”。
    3. 勾选“开放UDP端口”。
    4. 单击“增加”。
    说明：

    由于建立端口映射至少需要两个端口，可参考之前操作新建UDP端口即可。

  5. 根据已创建的端口信息，配置端口映射。
    1. 选择“端口类型”。
    2. 选择“入端口编号”和“出端口编号”。
    3. 选中“双向通道”，即表示同时添加反向映射关系。
    4. 单击“增加”，即在“端口映射表”中显示相应的端口映射关系。
  6. 外部程序可以向开放的端口号发送信息，实现与此开放端口建立映射关系的仿真设备进行通信。
父主题： FAQ


如何让SecureCRT连接到仿真设备后支持Tab键操作

  1. 打开SecureCRT软件，在主菜单中选择“选项 > 全局选项”，打开“全局选项”配置界面。
  2. 在左侧导航树中选择“常规 > 默认会话”，单击“编辑默认设置”，打开“会话选项”界面。

  3. 在左侧导航树中选择“连接”，并设置终端协议为“Telnet”。

  4. 在左侧导航树中选择“连接 > Telnet”，勾选“强制每次一个字符模式（R）”。

父主题： FAQ


如何解决使用eNSP工具时CPU利用率过高的问题

eNSP工具在开启模拟路由器后CPU占用率很高，我们可以通过开启虚拟化技术来解决这一问题。

  1. 在BIOS中开启虚拟化技术。
    1. 启动计算机时进入BIOS界面。
    2. 将光标移到“Virtualization”处，单击“Enter”键。
      说明：

      不同类型计算机的BIOS界面可能有差别，这里只是举个例子，还请参照实际情况进行选择。

      另外惠普电脑需要将VTx和VTd全部勾选。

    3. 在“Virtualization”界面中，将“Intel (R) Virtualization Technology”设置为“Enabled”。

    4. 保存后退出BIOS界面，进入操作系统。
  2. 打开VirtualBox工具，选中“AR_Base”，单击“设置”。

  3. 在“AR_Base — 设置”页面的左侧导航树中选择“系统”。

    单击“处理器”页签，将“处理器数量”设置为“2”。

  4. 单击“硬件加速”页签，选中“启用 VT-x/AMD-V”和“启用嵌套分页”。

  5. 单击“确定”。
父主题： FAQ


防火墙USG6000V如何登陆web网管

在使用Web方式登录设备前，需完成以下任务：

a. 设备的接入端口已配置IP地址。即防火墙g0/0/0端口配置IP地址，该IP地址需要保证和您本地计算机所在同一网段并且该地址未被使用。

b. 您的本地计算机已通过CLOUD设备与防火墙实现互通。

c. 设备正常运行，HTTP服务已正确配置。

d. 您的本地计算机上已安装浏览器软件。

图1 Web网管简单组网如下：

说明：
  • eNSP防火墙设备现只支持g0/0/0端口登录web网管对设备进行管理和配置。
  • eNSP云设备绑定本地网卡与仿真设备进行通信的设置，请参考FAQ：如何使用云设备。

操作步骤：

  1. 本地计算机打开浏览器软件（以火狐浏览器为例），在地址栏中输入“https://117.0.0.233:8443”（ 117.0.0.233为示例，请以以太接口中实际配置的接入端口IP地址为准），按下回车键，显示Web网管的登录界面。

    图2 Web网管登录界面

  2. 输入登录信息。

    a. 选择语言

    目前支持中文和英文。

    b. 输入用户名和密码。

    缺省用户名为admin，缺省密码为Admin@123。

    c. 单击“登录”，进入操作页面。

  3. 修改登录密码。

    首次登录WEB网管的用户，系统会强制要求修改密码。

    图3 修改密码界面

  4. 退出当前登录，单击页面右上角的“注销”，重新返回到登录页面。

    图4 web网管界面

  5. 用户登录成功后，在固定时间内未进行任何操作（缺省超时时间为10分钟），系统自动注销当前登录。单击“确定”后，重新返回到登录页面。
父主题： FAQ


如何解决云设备绑定网卡无法通信问题

云设备绑定网卡后，若本地计算机无法和模拟设备通信，需要检查一下所绑定网卡的设置。

操作步骤：

  1. 打开网络连接界面，选择云设备所绑定的本地网卡，右键单击并选择“属性”。

  2. 选择 Internet 协议版本4（TCP/IPv4），点击“配置”，进入配置界面。

  3. 进入高级选项，选择IPv4校验和卸载。

  4. 将“值”选项设置为已禁用。

  5. 如尝试上述方法之后仍不成功，则在virtualbox里进入管理->主机网络管理器（5.2版本以下的在管理->全局设定->网络里），再创建一个虚拟网卡如下：xxxxxx #2，IP会自动设置一个，DHCP不用启用。用云设备绑定新的虚拟网卡。

父主题： FAQ


如何解决AR/WLAN设备启动失败问题

现象描述

  1. 启动AR设备之后，设备命令行无法接收输入，在长时间等待后一直输出“####”。
  2. 启动AR/WLAN设备时，提示“…错误代码40…”。

处理步骤

  • 检查虚拟网卡设置。
    1. 检查安装eNSP的PC上是否存在名为“VirtualBox Host-Only Network”的虚拟网卡。

      - 如果不存在，请添加虚拟网卡。

      - 如果存在，请检查虚拟网卡的状态。

      - 如果虚拟网卡的名称为“VirtualBox Host-Only Ethernet Adapter #2”，可尝试点击eNSP主界面“菜单-工具-注册设备”重新注册设备。如果还是出现这样的错误，请检查虚拟网卡的状态。

    2. 检查虚拟网卡的状态。

      查看名为“VirtualBox Host-Only Network”的虚拟网卡是否被禁用。

      如果被禁用，请启用这个虚拟网卡。若重启设备仍然失败，请检查虚拟网卡的参数设置。

    3. 检查虚拟网卡的参数设置。

      检查虚拟网卡的设置是否符合以下要求：

      IP地址为192.168.56.1，子网掩码为255.255.255.0。

      同时取消选中“DHCP服务器”页签的“启用服务器”。

      如果设置正常，设备启动仍失败，请检查虚拟网卡属性设置。

    4. 添加虚拟网卡。
      1. 打开VirtualBox程序。
      2. 选择“管理 > 全局设定 > 网络”。

      3. 可选: 如存在其他的虚拟网卡，请先删除其他的虚拟网卡。
      4. 创建一个虚拟网卡，并进行如下设置。

        IP地址为192.168.56.1，子网掩码为255.255.255.0，同时取消选中“DHCP服务器”页签的“启用服务器”。

      按上面的步骤添加完虚拟网卡后，请再次尝试，如果还是出现这样的错误，请检查虚拟网卡属性设置。

  • 检查虚拟网卡属性设置。
    1. VirtualBox5.0版本中，选择“控制面板\网络和 Internet\网络连接”。
    2. 选中VirtualBox Host-Only Network网卡，右键选择属性，勾选 “VirtualBox NDIS6 Bridged Networking Driver”协议。

    3. 确定后，请重启工具再次尝试，如果还是出现这样的错误，请检查防火墙设置。
  • 检查防火墙设置。
    1. 在windows开始菜单中，选择“控制面板 > Windows防火墙”。
    2. 在“Windows 防火墙”页面中，选择“允许程序或功能通过Windows防火墙”。

    3. 在“允许的程序”页面中，查看“eNSP_VBoxServer”行“公用”列的勾选框是否选中。

    4. 如果没有选中，选中勾选框，单击“确定”。
    5. 重启eNSP工具后再次尝试，如果设备仍启动失败，请检查杀毒软件。
  • 检查杀毒软件。
    1. 检查电脑中是否安装QQ管家、百度杀毒、卡巴斯基等软件，此类软件阻止了模拟设备间的通信，导致模拟设备间的心跳报文无法互通。
    2. 如有安装，请卸载。重启eNSP工具后再次尝试。
    3. 如果还是出现这样的错误，请检查VirtualBox安装目录。
  • 检查VirtualBox安装目录。
    1. 检查VirtualBox安装目录是否存在中文字符。
    2. 如存在，修改VirtualBox安装目录为英文字符。
    3. 如果还是出现这样的错误，请检查硬件虚拟化设置。
  • 检查硬件虚拟化设置。
    1. 检查电脑是否开启硬件虚拟化支持。
    2. 如未开启设置，参照如何解决使用eNSP工具时CPU利用率过高的问题。
    3. 如果还是出现这样的错误，请联系华为公司服务工程师。
父主题： FAQ


如何解决交换机设备启动失败问题

现象描述

启动交换机后，设备命令行无法接收输入，在长时间等待后一直输出“####”。如何解决这个问题？

处理步骤

  1. 登录安装eNSP的PC机。
  2. 选择“开始 > 所有程序 > 附件”。
  3. 右键单击“命令提示符”，选择“以管理员身份运行”。
  4. 在弹出的命令行窗口中，输入相应的命令，重启计数器。

    • 对于Win7、Win8和Win10系统，输入“lodctr /R”。
    • 对于Windows xp系统，输入“lodctr /R:PerfStringBackup.ini”。

父主题： FAQ


如何解决USG5500启动失败问题

现象描述

启动USG5500设备之后，设备命令行无法接收输入，在长时间等待后一直输出“####”。

处理步骤

  1. 打开eNSP，点击“菜单->工具->选项”，或者工具栏“ [image] ”按钮；
  2. 选择“服务器设置”；
  3. 将“本地服务器”设置为127.0.0.1 ；
  4. 点击“确定”。

父主题： FAQ


如何解决CE、NE和CX设备启动失败问题

现象描述

  1. 启动CE、NE和CX设备设备之后，设备命令行无法接收输入，在长时间等待后一直输出“####”。
  2. 启动CE、NE和CX设备设备时，提示“…错误代码40…”。

处理步骤

  • 检查硬件虚拟化设置。

    检查电脑是否开启硬件虚拟化支持，参照如何解决使用eNSP工具时CPU利用率过高的问题。

  • 检查防火墙设置。

    请参照如何解决AR/WLAN设备启动失败问题中检查防火墙设置章节。

  • 检查虚拟网卡设置。

    请参照如何解决AR/WLAN设备启动失败问题中检查虚拟网卡设置章节。

  • 检查杀毒软件。

    请参照如何解决AR/WLAN设备启动失败问题中检查杀毒软件章节。

  • 检查VirtualBox安装目录。

    请参照如何解决AR/WLAN设备启动失败问题中检查VirtualBox安装目录章节。

父主题： FAQ


如何解决USG6000V启动失败问题

现象描述

  1. 启动USG6000V设备之后，设备命令行无法接收输入，在长时间等待后一直输出“####”。
  2. 启动USG6000V设备时，提示“…错误代码40…”。
  3. 启动USG6000V设备时，提示“…错误代码45…”。

处理步骤

■长时间输出“####”和错误代码40 解决步骤。
  • 检查硬件虚拟化设置。
    1. 检查电脑是否开启硬件虚拟化支持（使用USG6000V必要条件，若环境本身是虚拟机或无法开启硬件虚拟化，则无法使用此设备），参照如何解决使用eNSP工具时CPU利用率过高的问题。
    2. 如开启硬件虚拟化后，设备仍启动失败，请检查虚拟网卡属性设置。
  • 检查虚拟网卡属性设置。
    1. VirtualBox5.0版本中，选择“控制面板\网络和 Internet\网络连接”。
    2. 选中VirtualBox Host-Only Network网卡，右键选择属性，勾选 “VirtualBox NDIS6 Bridged Networking Driver”协议。

    3. 确定后，请重启工具再次尝试，若设备仍启动失败，请检查防火墙设置。
  • 检查防火墙设置。

    请参照如何解决AR/WLAN设备启动失败问题中检查防火墙设置章节。

  • 检查虚拟网卡设置。

    请参照如何解决AR/WLAN设备启动失败问题中检查虚拟网卡设置章节。

  • 检查杀毒软件。

    请参照如何解决AR/WLAN设备启动失败问题中检查杀毒软件章节。

  • 检查VirtualBox安装目录。

    请参照如何解决AR/WLAN设备启动失败问题中检查VirtualBox安装目录章节。

■错误代码45解决步骤。
  • 重新注册设备。
    1. 打开VirtualBox查看是否有 vfw_usg_Clone_***之类和vfw_usg的链接，如有则删除。
    2. 单击VirtualBox “管理 - 虚拟介质管理”，将vfw_usg.vdi删掉，如提示无法删除，先删除vfw_usg.vdi下面的子链接，然后再删除vfw_usg.vdi。

    3. 重新导入vfw_usg.vdi文件。打开eNSP客户端，在工作区添加一台USG6000v设备，开启时出现导入弹窗，添加解压生成的vfw_usg.vdi包路径，导入即可。

完成以上步骤后，重新启动USG6000v。

父主题： FAQ


如何正确使用USG6000V

在使用USG6000V设备前，需完成以下任务：

  1. 已安装最新版eNSP客户端。
  2. 在BIOS中开启虚拟化技术。
    1. 启动计算机时进入BIOS界面。
    2. 将光标移到“Virtualization”处，单击“Enter”键。
      说明：

      不同类型计算机的BIOS界面可能有差别，这里只是举个例子，还请参照实际情况进行选择。

    3. 在“Virtualization”界面中，将“Intel (R) Virtualization Technology”设置为“Enabled”。

    4. 保存后退出BIOS界面，进入操作系统。

操作步骤：

  1. 在官网上下载最新版USG6000v.zip。

    下图以 eNSPv1.2.00.380 版本为例：

  2. 解压USG6000v.zip生成vfw_usg.vdi文件。
  3. 导入vfw_usg.vdi文件。打开eNSP客户端，在工作区添加一台USG6000v设备，开启时出现导入弹窗，添加解压生成的vfw_usg.vdi包路径，导入即可。

  4. 完成以上步骤后，重新启动USG6000V。
父主题： FAQ


如何正确使用CE、NE和CX设备

  1. 在官网上下载最新版CE.zip、NE40E.zip、NE5KE.zip、NE9K.zip和CX.zip

    (510版本及之前CE设备包为CE6800.zip)。

  2. 分别解压zip文件生成CE.img、NE40E.img、NE5KE.img、NE9K.img和CX.img文件。
  3. 打开eNSP客户端，在工作区添加一台CE12800设备，开启时出现导入弹窗，添加解压生成的CE.img包路径，导入即可。如下图：

    完成以上步骤后，再启动一次设备就可以了。

  4. NE40E、NE5KE、NE9K和CX的启动与CE12800相同。
    说明：
    • 建议不要同时启动超过2台NE40E设备。请在设备启动完毕，可进入命令行后，再尝试启动更多设备。
    • 如果启动过程中，出现如下提示框，是因为你的机器上没有按照第一步开启虚拟化。

    • 如果你的电脑没有开启硬件虚拟化支持，建议参照如何解决使用eNSP工具时CPU利用率过高的问题。
父主题： FAQ


如何注册eNSP设备

  • 重新注册AR、WLAN设备：

    启动AR时，如果提示“启动设备AR失败.错误代码：41……”信息。

    1. 打开vbox，将所有**_Base鼠标右键点击删除->删除所有文件：

    2. 打开vbox中左上角菜单->管理虚拟介质管理，将里面的文件删除（如下图），如果删除不掉就先删除下拉箭头的类似：29a2d98c-4da0-4e86-8e4e-768cc7f81b61.vdi，另外出现任何报错都不要在意，确定即可。（如果虚拟介质管理是空的则跳过这一步）

    3. 然后打开eNSP安装目录下的vboxsever文件夹，找到下图五个文件夹并删除。

    4. 打开eNSP，不要添加任何模拟设备，直接单击“菜单 - 工具 - 注册设备”，将所有设备勾选并重新注册下。

  • 重新注册USG6000V设备：
    1. 前两步同•重新注册AR、WLAN设备：中1、2步，先将vbox侧残留清理干净。
    2. 打开eNSP安装目录下的\plugin\ngfw\Database文件夹，删除vfw_usg.vdi（如果没有则跳过此步骤）。
    3. 打开eNSP，拉取一台USG6000V，启动设备，然后弹框导入设备包。
  • 重新注册NE设备：
    1. 前两步同 重新注册AR、WLAN设备：中1、2步，先将vbox侧残留清理干净。
    2. 打开eNSP安装目录下的\plugin\ne\Database文件夹，删除NE40E.vdi（如果没有则跳过此步骤）。
    3. 打开eNSP，拉取一台NE40E，启动设备，然后弹框导入设备包。
  • 重新注册CE设备：
    1. 前两步同 重新注册AR、WLAN设备：中1、2步，先将vbox侧残留清理干净。
    2. 打开eNSP安装目录下的\plugin\svrp\Database文件夹，删除CE.vdi（如果没有则跳过此步骤）。
    3. 打开eNSP，拉取一台CE6800或者CE12800，启动设备，然后弹框导入设备包。
父主题： FAQ


如何添加自定义设备

背景信息

eNSP支持用户自定义开发仿真设备，通过插件的方式集成到eNSP平台，软件组织结构图如下。

用户开发完成自已的仿真设备后，需要参考“eNSP第三方插件接口规范”(该文档路径：eNSP安装路径/help/eNSP第三方设备接口说明.docx)，开发一个适配dll，通过该dll实现自己的仿真设备与eNSP进行对接。

自定义仿真设备和适配dll开发完成后，在eNSP界面上进行参数配置，即可将自定义仿真设备添加到eNSP软件平台。

操作步骤

自定义仿真设备配置界面分为三个区域：产品类型区、产品型号区、接口信息区。我们以CE12800为例介绍自定义设备的具体配置过程。

  1. 打开eNSP，点击“菜单->工具->添加/删除设备”打开自定义仿真设备参数配置对话框。

  2. 自定义产品类型。目前eNSP平台的产品类型有：路由器、交换机、防火墙、无线局域网、终端以及其他设备。该区域中，您可以自定义各个产品类型在eNSP设备区显示的图标及名称。CE12800属于交换机，所以我们在产品类型中选择“交换机”。
  3. 增加产品型号。产品型号区可以添加用户自定义开发设备的具体产品型号。
    1. 点击产品型号的 [image] 按钮，修改设备型号为CE12800；
    2. 点击设备图片，更换CE12800在eNSP平台上各区域显示的图片；
    3. 在设备描述中添加CE12800的描述信息；
    4. 勾选“绑定virtualbox host-only虚拟网卡IP(192.168.56.1)”；
      说明：

      CE12800没有自己的虚拟网卡，它基于virtualbox host-only虚拟网卡与eNSP通信，所以我们勾选该项，用户可根据自己的仿真设备的实现方式，选择勾选或不勾选。

    5. 不勾选“设备支持心跳”；
      说明：

      CE12800不支持通过心跳报文维持网络通信功能，所以不勾选该项，用户可根据自己仿真设备的实现方式，选择勾选或不勾选。

    6. 选择插件路径，选择开发的适配dll文件路径。
  4. 设置产品接口信息。本区域可添加自定义仿真设备上的接口信息，以CE12800为例。
    1. 首先，为CE12800添加主控板。

      1. 选择槽位号17（CE12800中定义的主控板的卡槽ID为17，用户可根据自己仿真设备中的定义来设置）；
      2. 设置卡槽类型：mmb-268438017（具体卡槽类型与用户在适配dll和自定义仿真设备中定义相关，如果没有定义，这里可以不写）；
      3. 勾选“是否为主控板”。
    2. 然后，在卡槽1上添加一块接口卡。
      1. 选择槽位号 1，卡槽类型：lc-268438083(具体卡槽类型与用户在适配dll和自定义仿真设备中定义相关，如果没有定义，这里可以不写)；
      2. 不勾选是否为主控板；
      3. 选择接口卡eagf_10GE，点击 [image] 添加至设备。
      4. 接口名称中显示的槽位号：1(设置当前卡槽在ensp平台上接口连线时显示的编号，效果参见预览区域)；
      5. 接口名称中显示的卡编号：0(设置当前接口卡在ensp平台上接口连线时显示的编号，效果参见预览区域)；
        说明：

        卡槽类型以及接口卡类型根据用户自定义仿真设备中定义来配置，如果用户自定义仿真设备包中未定义，那么用户可以自定义配置卡槽类型和接口卡类型名称。当系统中没有适合您的接口卡时，可以通过点击“支持的接口卡”后面的 [image] ，添加一块适合您自己的接口卡。具体操作方法参见添加其他接口卡。

      6. 点击“生成”按钮。
  5. 导入自定义设备包。配置完成后，重启eNSP，在设备区会出现添加的自定义设备图标。
    1. 拖拽添加自定义设备到工作区；
    2. 右键选中该自定义设备图标，选择“启动”，会弹出提示用户导入自定义设备包的提示框；
    3. 点击浏览，选择自定义的设备包，单击导入，导入设备包。
      说明：
      • CE12800与CE6800、NE40E使用同一个设备包，在eNSP官方下载页面下载CE6800的设备包。
      • 只有第一次启动自定义设备时，需要导入设备包，后续使用无须重复导入。
  6. 添加其他接口卡。

    拓展设备使用过程中如需要的接口卡不在现有接口卡列表中，那么您可以自己创建符合要求的接口卡。下面以2口的POS卡为例。

    1. 点击接口信息中 [image] 按钮；
    2. 修改接口卡名字 为：POS_2(名字可以自定义)；
    3. 设置接口卡类型为：p2uf-1073741841；
    4. 设置接口类型为：POS；
    5. 设置接口个数为： 2；
    6. 设置接口起始编号为：0；
    7. 确认信息无误后，点击生成。
      说明：

      添加完自定义接口卡后，请参考CE12800在卡槽中添加接口卡的步骤，添加至您所需要使用该接口卡的设备中。

父主题： FAQ


AC设备如何登陆web网管

在使用Web方式登录设备前，需完成以下任务：

a. 设备的接入端口已配置IP地址，该IP地址需要保证和您绑定的网卡所在同一网段并且该地址未被使用。

b. AC设备需要配置admin级别。

c. 您的本地计算机已通过CLOUD设备与AC实现互通。

d. 设备正常运行，HTTP服务已正确配置。

e. 您的本地计算机上已安装火狐浏览器软件。

图1 Web网管简单组网
说明：
  • eNSP云设备绑定本地网卡与仿真设备进行通信的设置，请参考FAQ：如何使用云设备。

操作步骤：

  1. 在配置好云设备和AC参数，并且确定互相ping通之后，打开本地火狐浏览器，在地址栏输入“https://10.134.179.1”（ 10.134.179.1为示例，请以以太接口中实际配置的接入端口IP地址为准），按下回车键，显示Web网管的登录界面：
    图2 web网管登陆界面
  2. 输入登陆信息。
    1. 选择语言。

      目前支持中文和英文。

    2. 输入用户名和密码。

      缺省用户名为admin，缺省密码为admin@huawei.com。

    3. 单击“登录”，进入操作页面。
  3. 修改登陆密码。

    首次登陆web网管的用户，系统会强制要求修改密码。

    图3 修改密码界面
  4. 退出当前登录，单击页面右上角的“注销”，重新返回到登录页面。
    图4 web网管界面
  5. 用户登录成功后，在固定时间内未进行任何操作（缺省超时时间为10分钟），系统自动注销当前登录。单击“确定”后，重新返回到登录页面。
父主题： FAQ


如何手动修改NE、CX和CE设备的内存

  1. 先将virtualbox虚拟机设置成以管理员身份运行此程序（win10系统需要多设置一个"以win7兼容性模式运行程序"），如下图：

  2. 打开virtualbox虚拟机并关闭eNSP模拟器，使svrpbox的状态为已关闭。

  3. svrpbox->右键->设置->系统->主板，将内存大小调整到绿色和红色中间。

  4. svrpbox->右键->设置->系统->处理器，将CPU数量调整到合适的大小。

  5. 重新打开eNSP客户端，拉入设备并启动。
    说明：

    老版本的CE设备包名字为svrpbox.img，新版本新增了NE40E设备包NE40E.img，同时将CE设备包更名为CE.img。这两个设备包的手动更改内存过程与上面步骤相同。

父主题： FAQ